2 Replies Latest reply: Dec 26, 2013 10:20 AM by EZEVANS
molson1177 Level 1 Level 1 (0 points)

I’m pretty new to a lot of this stuff, so I hope this makes a little bit of sense.  I recently bought the fcb1010 to use with Mainstage 2.  I have been following the JasMan tutorials, among many others, and been digging through comments and comments and still can’t get this thing to work! First I tried the Midi- in and out connection through my Saffire PRO 24 DSP, and I downloaded ifcb.  I tested my midi cables, they are fine.  Read somewhere that the Saffire might not support Sysex.  So now I’m using my M-Audio fast track pro.  I set my ifcb CC numbers up as shown in the tutorials, also tried some combinations from other tutorials.  Successfully sent it to the controller (I think) via SYSEX transfer.  The FCB1010 consistently shows up as connected to ifcb1010, although once in a while I have to restart my computer to get it to read. One thing I noticed is that if I control the foot pedals with my feet, the LED displays will change on ifcb, however, if I click on pedal graphics in ifcb, there is no change in the physical controller (the lights stay on in the same places).

Okay, so I followed all the steps in your tutorial, however, Mainstage will not learn any commands.  Sometimes when I press the foot controller MS will not show any midi information in the display at the top, however, if I go into performance mode and press my controller, it will jump around from patch to patch and set to set in a seemingly random manner.  Sometimes the Midi-information does show at the top, but it always is displayed as  [ X 16 0 0].  This is after the set-up in ifcb and sysex transfer.

In layout mode, the only device that shows up is my fasttrack, I can’t get the FCB1010 to show up.  I can change the controls in layout mode from yellow to black if I change the channel manually, however when I change the number manually it still seems to have no effect.  Regardless, the learn function is not working.  The last thing I have done is used MIDI monitor…each pedal and the expression pedals show up as a different data number on the same channel number (1). I’ve spent many hours trying to figure this out with a lot of trial and error along with all the sequential things I’ve read and seen on tutorials, it seems I keep hitting roadblocks!  The only thing I can think of that maybe could be the problem is that my midi-in port on the FCB is not functioning (maybe)? When I run the relay test on the FCB1010, it reads F1, not A1.