4 Replies Latest reply: Feb 23, 2013 2:04 PM by chas_mac
chas_mac Level 1 Level 1 (0 points)

I have a Dual 2.3 GHz Power PC G5 and its running OS10.5.8

 

Itunes is version 9

 

Iphone is IOS 6.1

 

Problem: When I connect my Iphone it will not connect to Itunes. The error says that I need itunes 10.6.3

 

Can anyone tell me whats going on here

 

thanks

  • Niel Level 10 Level 10 (274,605 points)

    It's right. You need to install iTunes 10.6.3, which is free for people using 10.5.

     

    (75910)

  • chas_mac Level 1 Level 1 (0 points)

    Im sorry I failed to mention that the error said I need itunes 10.6.3 or later.

     

    Shouldnt itunes 9 work?

     

    Do I have to back itunes down to 10.6.3 even though Im running itunes 9 now?

     

    thanks

  • Monk E. Boy Level 1 Level 1 (5 points)

    iTunes 10.6.3 is higher than iTunes 9. In other words, iTunes 10 is greater than iTunes 9.

  • chas_mac Level 1 Level 1 (0 points)

    ICloud Issue

     

    I have a Dual 2.3 GHz Power PC G5 and its running OS10.5.8. My version of Safari is 5.0.6.  I have an Icloud account and its all working fine except that I can get into the Mail application in Icloud.  Im assuming this is a limitation of Safari running on this older machine. Is there a newer version of Safari that I can update to or is there another browser that I can install on this machine that will work better with Icloud.

     

    thanks.