7 Replies Latest reply: Feb 5, 2013 4:15 AM by david_sivaraj
ysimhoni Level 1 Level 1 (0 points)



I have recently updated to iOS 6.1. I am not sure if this is related, but for some reason I can't download large apps (I'm on wifi and the connection is super fast).

At first I was trying to update 2 games I have on my iPhone 5, and it didn't download. I thought this was a result of me getting in and out of range. Anyway, I have deleted those 2 apps, hard reseted the device, and tried to download a fresh copy. It still doesn't work. I have even had my network settings reseted to no avail.

Smaller apps usually updates fine, even though the app store seems a but slugish in general.


Any ideas?

iPhone 5, iOS 6.1
  • sberman Level 7 Level 7 (27,490 points)

    Try to download only one app at a time.  If two or more are simultaneously trying to download, press their "Waiting" buttons to get them to the "Paused" state, then press one to start it and let it complete.  Then repeat until done.

  • alanfromwickford Level 1 Level 1 (10 points)

    as above answer, it happened to me and the wife before we updated.


    i seem to remember a while back clicking to allow simultaneous downloads somewhere, but i can't find where to turn it off :(

  • sberman Level 7 Level 7 (27,490 points)

    My reply above explains how to turn them off.

  • ysimhoni Level 1 Level 1 (0 points)

    Hi, this still doesn't help.


    I have tried to download only one app at a time, and apparently, the problem is the connection to the server being impossibly slow. I have downloaded "ARC Squadron" in more than a few hours now. I'm now trying to update Facebook, and it is taking forever. I'm using the same connection with my iPad and with an iPhone 4 and everything seems to be working just fine.


    What could be the cause of the slow connection to Apple's servers? It seems very odd to me.

  • ysimhoni Level 1 Level 1 (0 points)

    BTW, this happens only on wifi, while the speedtest app still shows a fast connection.

  • alanfromwickford Level 1 Level 1 (10 points)

    i appreciate about manually queuing stuck downloads, but it was asetting somewhere you can make it the default (one by one) :).

  • david_sivaraj Level 1 Level 1 (0 points)

    Since the upgrade the following has happened:


    I can not download app updates, even though I have a badge saying there is, but when I go to the screen, it's empty.  I am using the apple ID I always use.


    Also, iMessage uses an old number, and I am not able to delete it from my list.  I have been advised by the current owner, that they receive a copy of my iMessages.  I have unticked from my list, but it still sends copies to that number.  I am unable to find another way of deleting that number.  I am forced to travel interstate to see if I can resolve the issue on the old phone.