4 Replies Latest reply: Mar 21, 2014 8:10 AM by KB_Thailand
destwo Level 1 Level 1 (0 points)

Trying to setup apple airport. It will not connect to the internet. Message is WiFi has a self assigned IP address 169.254.194.208 and will not be able to connect to the internet.


airport extreme, Mac OS X (10.7.5)
  • 1. Re: apple extreme will not connect to internet, says that WiFi has a self assigned IP
    Philly_Phan Level 6 Level 6 (11,705 points)

    I'm a great believer in the KISS principle.

     

    Configuration is simple if you start from a factory default condition.  Then connect the Airport to AC power and finally to the Internet modem (or modem/router).  Open Airport Utility on your Mac or other computer and accept all of the recommendations.  After confirming that it works, insert your desired administrative and WiFi passwords.

     

    Do not expect the Airport to respond instantly to the configuration commands.  BE PATIENT!

  • 2. Re: apple extreme will not connect to internet, says that WiFi has a self assigned IP
    AudioMekhanik Level 1 Level 1 (0 points)

    This does not help. Thanks for the suggestion.

  • 3. Re: apple extreme will not connect to internet, says that WiFi has a self assigned IP
    AudioMekhanik Level 1 Level 1 (0 points)

    Reinstall your OS or upgrade to the newest version that you can. I upgraded from 10.3.9 to 10.4 Leopard and it instantly solved my internet issues. I realize I'm using an older machine and OS but upgrading worked.

  • 4. Re: apple extreme will not connect to internet, says that WiFi has a self assigned IP
    KB_Thailand Level 1 Level 1 (0 points)

    Ok, after reading through loads of stuff about this problem, and trying all of the solutions offered, I came up with a workaround for my machine.  NONE of the suggested fixes worked...deleting files, changing PW type in the router, manually assigning IP addresses, etc., etc., and in fact I *STILL* cannot login directly to my router, so this is STILL a HUGE issue!  If I try to login through the router directly, I still get the dreaded 'WiFi has no IP address' error and it self assigns. The last contact with the internet according to the logs was at 3:03 AM local time (GMT+7) this morning Mar 21, 2014, so it definitely was not something *I* did.  I looked for a log listing update installs, but could not find one, so I have no idea if an update caused the issue.  It worked fine for the last two years with no issues, so why did it suddenly quit working at 3:03 in the morning? A good question for Apple!

     

    My workaround: (definitely NOT a solution)

    I have a TimeMachine/TimeCapsule, and set it up to be a wireless base station.  Easy enough, but you have to watch the IP's.  It will probably assign an IP outside the range your router is set to.  My router, like many, is 192.168.1.1, so I set the IP to static and changed the IP address of the TimeMachine to 192.168.1.2 from 169.something and assigned the network range from 192.168.1.3 to 192.168.1.200.  So after twelve hours of reading and trying many different things, always getting more and more frustrated, a half hour was what it took to make a workaround.  My MBP can now get on the internet!  WOO-HOO!

     

    However, it is scary how many people are having this issue, and it would behoove Apple to figure out what the REAL issue is and fix it!!!  I am pretty technically proficient, but I cannot imagine if my wife were trying to solve this problem!  It does not normally take me 12.5 hours to solve something, or figure out a workaround, which points to how nasty this issue is!

     

    KB