Previous 1 2 3 Next 39 Replies Latest reply: Mar 29, 2015 12:12 AM by superego805
anssi Level 1 (0 points)



I upgraded a few days ago to OSX 10.8 from 10.6, but now my Canon LBP6300dn is not working. The printer is connected to my router (ethernet) and I'm using WiFi on my MBA.


Firstly, even if I follow the instructions that come with the driver I get an error message that says: "Cannot connect to printer." Secondly the problem is that when I print a page it get an error message that says: "Printer busy". I tried to re-install the drivers, but nothing helps. Has someone else had this same problem?

MacBook Air, OS X Mountain Lion (10.8.2)
  • anssi Level 1 (0 points)

    I have pretty much the same problem as described here:

  • PAHU Level 6 (15,930 points)

    Since you upgraded from 10.6, I suggest you remove the CAPT driver files. The first step is to remove the LBP6300dn printer from Print & Scan.


    Next, open Finder and select Go > Go to Folder. Then type in /Library/Printers/Canon/ and press Go. This will take you to the Canon folder and you will see the CUPSCAPT folder. Trash this folder.


    Still in Finder, navigate to /Library/LaunchAgents and trash the file ""


    Restart the Mac and after you log back in, run the CAPT v3.55 installer. When completed, add the printer again and see if this will print. Note that you must use the LPD protocol.

  • anssi Level 1 (0 points)

    Nothing changed. I still get the same error messages:


    Just before adding my printer:

    "Unable to verify the printer on you network.


    Unable to connect to "IP adress:..." due to an error. Would you still like to create the printer?"


    And if I press "Continue" and try to print the error message is "The printer is busy".

  • PAHU Level 6 (15,930 points)

    Can you open System Information (Applications > Utilities) and select the Printers entry in the left column. The top right pane will show the LBP6300dn connection. Select this and the bottom right pane will show information about the printer. Can you select all this LBP6300 information, copy and then paste back here for me to check.

  • anssi Level 1 (0 points)

    I suppose you mean this information:


    anon LBP6300:


      Status:          Idle

      Print Server:          Local

      Driver Version:          3.55

      Default:          No

      Shared:          No

      URI:          lpd://

      PPD:          Canon LBP6300 CAPT (UK)

      PPD File Version:          3.55

      PostScript Version:          (3010.000) 550

    (3010.000) 651

      CUPS Version:          1.6svn (cups-327)

      Scanning support:          No

      Printer Commands:          none

      CUPS filters:


      Path:          /Library/Printers/Canon/CUPSCAPT/Bins/capdftopdl

      Permissions:          rwxr-xr-x

      Fax support:          No

      Printer utility:          /Library/Printers/Canon/CUPSCAPT/StatusMonitor/

      Printer utility version:          3,55



      Sandbox compliant:          Yes

  • PAHU Level 6 (15,930 points)

    Thank you for supplying that. This is the information I wanted.


    This shows that your printer queue has not been created correctly, which is shown next to URI. Your Mac has




    While a correctly configured LBP6300 that is networked should have a URI of




    The most common cause for the printer queue not being created correctly is the CAPT Backgrounder process not running. You can check this by opening Activity Monitor and looking through the list. If you see the Canon CAPT Backgrounder in the list, then it is running and there is some other cause. But if you do not see it, then you will need to manually start it.


    To start the Canon CAPT Backgrounder, open Finder and select Go > Go To Folder. Then type in




    And press Go. This will display the Canon CAPT Backgrounder file. Double-click this file. Nothing will appear on the Mac but if you check Activity Monitor, you should now see it. If you do, you can remove the current LBP6300 from Print & Scan and add it again, selecting LPD for the protocol as before. With the CAPT Backgrounder running the printing should now work. If it does not, check you can see the CAPT Backgrounder in Activity Monitor and also check the print queue URI in System Information.

  • anssi Level 1 (0 points)

    Pahu, thank you for taking your time!


    The Canon CAPT Backgrounder was indeed not running. I started it, removed the printer and added it again. Unforgently nothing changed... I get the same error messages and it seems like the URI is wrong..



      Status:    Idle

      Print Server:    Local

      Driver Version:    3.55

      Default:    No

      Shared:    No

      URI:    lpd://

      PPD:    Canon LBP6300 CAPT (UK)

      PPD File Version:    3.55

      PostScript Version:    (3010.000) 550

    (3010.000) 651

      CUPS Version:    1.6svn (cups-327)

      Scanning support:    No

      Printer Commands:    none

      CUPS filters:


      Path:    /Library/Printers/Canon/CUPSCAPT/Bins/capdftopdl

      Permissions:    rwxr-xr-x

      Fax support:    No

      Printer utility:    /Library/Printers/Canon/CUPSCAPT/StatusMonitor/

      Printer utility version:    3,55



      Sandbox compliant:    Yes

  • PAHU Level 6 (15,930 points)

    Yes, unfortunately the URI is still wrong.


    Let's try again.


    1. Remove the LBP6300 from Print & Scan

    2. Open Finder and select Go > Go To Folder. Then type /Library/Caches/Canon/CUPSCAPT/CCPD and press Go. Trash the ccpd.conf file.

    3. Open Activity Monitor and check that Canon CAPT Backgrounder process is running.

    4. If process is running, open Print & Scan and add LPB6300 again.


    If this still fails to create the URI correctly then can you open Safari and type and press Return on keyboard. This should connect to the internal web page of the LBP6300. Can you confirm this happens.

  • anssi Level 1 (0 points)

    Unforgently the URI was again not created correctly.


    I can confirm that it is possible to connect to my printer in my browser.

  • PAHU Level 6 (15,930 points)

    Thanks for confirming you can open the web page.


    Few more things to check.


    1. Open Finder and use the Go > Go To Folder menu. Type in /Library/LaunchAgents and press Go. Do you see a file called ""?


    2. Still using Finder, select Go > Go to Folder and type in /Library/Caches/Canon/CUPSCAPT/CCPD and press Go. Can you open the ccpd.conf file, copy the entire contents and paste back here.


    3. Open Print & Scan and select the LBP6300. Then open Options & Supplies and select the Utilities tab. Then press Open Printer Utility. Does the CAPT Statusmonitor open or do you get an error message about no printer is found?


    4. When you add the printer in Print & Scan, are you still getting the error message "Unable to verify printer"? If yes, then I think there could be some port blocking with the wireless to Ethernet connection. What brand and model of wireless router do you have?


    FYI - My testing has been iMac > Ethernet > Hub > Ethernet > LBP6300. But tomorrow I want to try iMac > wireless > Router > Ethernet > LBP6300.

  • anssi Level 1 (0 points)

    1. Yes, it's there.


    2. No, there is no such file.


    3. When I tried to open then Utility I got an error message: "

    ”There are no registered  printers. Add a printer and then restart the Statusmonitor. The Statusmonitor will now be terminated.”


    4. I didn't make this step yet because the conf file is missing. Is that the problem?

  • PAHU Level 6 (15,930 points)

    Thanks for the reply.


    Since you do not have a ccpd.conf file in the CCPD folder, then this explains the failure to print. But the presence of the file is a result of creating the printer queue, not the other way around. By that I mean that you don't need this file to create the printer. The file gets created when you create the printer. So with this file not being created when you add the printer, then it suggests to me that you have some other issue with this CAPT driver.


    The other thing that is a concern is the "Unable to Verify" message you get when you try to add the printer. I think this is a key. I am yet to do my wifi testing. I'll see if that could be a possible cause.

  • anssi Level 1 (0 points)



    I'm a bit doubtful that something in the setup could cause the error. Anyway, thanks for investigating this..



    My connection to the printer is as follows: Macbook Air (OS X 10.8.2) – WiFi – Netgear WNR3000 – ethernet cable – Canon LBP6300dn.


    Earlier with OS X 10.6.8 it worked seamless and it still does with my MBP (OS X 10.6.8).

  • PAHU Level 6 (15,930 points)

    Managed to test the wireless connection from the iMac, basically the same as your setup.


    With this connection I would get the "Unable to verify the printer on your network" message. But if I pressed the continue button the printer was added and I was able to print to it.


    Looking at the "Registering OS X Lion" document included with the driver, that explains how to add the USB and networked CAPT printer, there is mention that this message can appear and just to press Continue. So it appears that this is not the issue that I thought it was.


    With all the testing I have done, the only way I can get the queue to be created incorrectly is to stop the CAPT Backgrounder. This results in the queue showing lpd instead of cnbma and the ccpd.conf file not being created. But with the Backgrounder process running, as you have confirmed yours is, then the queue is created correctly and the ccpd.conf is also created.


    I will do more testing when I can, which doesn't get you printing in the meantime from 10.8, but you may have to print from the MBP running 10.6.8 until I get a fix.

Previous 1 2 3 Next