0 Replies Latest reply: Feb 3, 2013 12:00 AM by ianlguzman
ianlguzman Level 1 Level 1 (0 points)

I recently ordered online a Mac OS X Snow Leopard from US Apple Store and installed this in my old MacBook bought in 1998. You might have ask why I bought this since I can downlown the latest version of Mountain Lion. Definitely not because snow leopard is a pre-requisite in order to download it! I bought the new iphone5 but I cant sync all my music, photos and videos because I needed a latest version of itunes which I cant download coz my macbook has the older version, I need 10.6, mine is 10.5. Instead of buying a new macbook, i opted to buy & installed Snow Leopard. Thanks to that, I had sync all the music, photos & videos I like from my own mac, I'm satisfied now.

My problem now is that I cant open my safari browser it says "you can't use this version of application Safari with my newly installed version of Mac OS X 10.6.3". Oh my! I have been up the whole night just to download the latest version of Safari 5.1.7 from Apple Store reinstalled Mac OS X update combned, Security Update 2012-004, I carefully followed instructions on downloading/installing/troubleshooting but still cant open.

Can someone teach me how to solve this?


MacBook (13-inch Early 2008), iOS 6.0.1