7 Replies Latest reply: Feb 3, 2013 11:33 AM by Old Toad
Mysdak Level 1 (0 points)


Just purchased an Imac (first time mac user) and imported all my photos from my PC.  I have been using photo stream on my phone and ipad and like it.  The problem is, as far as I can tell, that I have added thousands of photos to the Imac and it now consider those to be new additions.  It is sharing those photos to my phone and Ipad and filling both up very quickly.  Is there a way that I can only stream photos from the phone to Iphoto on my imac and not from the imac to the phone?  I realize that in 30 days, this should correct itself, but for the time being it is a huge hassle.  Im sure there is some setting in iphoto that will alleviate my problem

iMac (21.5-inch Mid 2011)
  • KarenSelena Level 4 (1,960 points)

    If you have a mac....


    launch iPhoto


    click the word "iPhoto" beside the apple, and select "preferences / photo stream"


    what synces, is listed here


    uncheck what you desire, and simply close iPhoto.  It will save the changes




    Click the apple / system prefences / iCloud - if you wish to stop "photo stream" completely, you can uncheck it here.


    Photo Stream FAQ - http://support.apple.com/kb/HT4486.

  • Mysdak Level 1 (0 points)

    Yes I have both automatic import and automatic upload unchecked.  Unfortunately, it appears that my iphoto has uploaded the images that I just transfered onto the hard drive to icloud, and inturn, they download to my phone.  Is there a way that it can be one way...from my phone to my imac.  I don't need images that I download to my computer being sent back to my phone.

  • Old Toad Level 10 (135,517 points)

    Setup iPhoto's Photo Stream preferences this way:


    That is UNCHECK THE AUTOMATIC UPLOAD radio button.



  • Mysdak Level 1 (0 points)

    Thanks...I think I will have to wait 30 days to clear what has been uploaded to icloud before this will work...unless there is a way to clear the icloud.

  • Old Toad Level 10 (135,517 points)

    I think you could select the photos in the Photo Stream in iPhoto and remove them from the photos stream by right clicking on them:


    That should clean them from your iPnone.

  • Mysdak Level 1 (0 points)

    found the answer elsewhere for my second problem  Logged into icloud online and clicked on my user name in top right hand corner.  Went to advanced and deleted my photo stream.  Worked.


    Thanks for all the help

  • Old Toad Level 10 (135,517 points)

    Thanks for the feedback.