Previous 1 2 Next 27 Replies Latest reply: Jul 6, 2014 1:59 AM by LAOMUSIC ARTS
joefromgreensburg Level 1 Level 1 (0 points)

When I play 2 or more notes on my MIDI keyboard that is hooked up to my computer (logic pro) it plays a note when I let go of the 2 or more keys. This doesn't happen when I play one note! WHY? HOW DO I FIX THIS? I tried turning off local control that didn't work. My MIDI controller is a KR-11 Roland Piano.


MacBook Pro, Mac OS X (10.7.4)
  • The Art Of Sound Level 6 Level 6 (10,115 points)

    Odd problem huh?

     

    First some basic troubleshooting....

     

    Try unplugging your midi in cable to the KR-11(so you only have a cable going from the Midi Out of the KR-11 to your midi interface)  and then test and see if you get the same problem.

     

    This will help identify/eliminate any midi loopback issues you may be having.

  • joefromgreensburg Level 1 Level 1 (0 points)

    Yes same problem except now I can't hear double notes while I am recording but when I look over at my computer double notes are still showing up after I play 2 or more notes! Then on top of that I can't hear what I have recorded afterwards, it won't play sound when I hit play in logic pro

  • The Art Of Sound Level 6 Level 6 (10,115 points)

    Well, you won't hear the sounds from your KR-11 because we disconnected the Midi In cable....

     

    Make sure you turn off Local Control off on the KR-11 and Leave it off when using the KR-11 with Logic... as that will cause double notes to sound (Local On will cause you will hear the note being sent directly from your keyboard to your sound engine inside your KR-11 and you will also hear the note being sent from your keyboard to Logic and then back to the sound engine in your KR-11) You can then reconnect the Midi cable back to the Midi in of your KR-11 and hear the sounds being played.

     

    As for why you are seeing double notes recorded as Midi even with the Midi In on your KR-11 disconnected is a little odd however...

     

    Have you tried changing presets on your KR-11 to make sure it happens when playing different presets or is it just one Preset that causes this? For example, make sure your KR-11 is not playing a layer or split sound preset.... (A Layer would give you two outgong notes possibly.. one for each layer being sounded)

  • joefromgreensburg Level 1 Level 1 (0 points)

    Ok how am I supposed to record if I disconnect the MIDI in cable and turn off local control, now there is no sound coming from the KR-11

  • The Art Of Sound Level 6 Level 6 (10,115 points)

    You misunderstood what I said.

     

     

    Make sure you turn off Local Control off on the KR-11 and Leave it off when using the KR-11 with Logic...

     

    Followed by....

     

    You can then reconnect the Midi cable back to the Midi In of your KR-11 and hear the sounds being played.

  • joefromgreensburg Level 1 Level 1 (0 points)

    Do you think I did something in Logic Pro 9 to cause the double notes, like duplicate layers or something? It still does the same thing :/ EDIT: i checked the event list and Recored while watching it, it is recording the notes when i hit them on the keyboard AND when I release them.

  • The Art Of Sound Level 6 Level 6 (10,115 points)

    No.. I think it is your KR-11 that is producing double notes because you are playing either a Layer or Split preset on it...

     

    Did you check to make sure that was not the case?

     

    You can test out Logic itself by disconnecting your KR-11 completely and then using Logic's built in musical keyboard to make sure it is not Logic that is generating double notes...

     

    Create a Software Instrument track

     

    Sel;ect that track.

     

    Choose a Software Instrument from the browser

     

    Press the Caps Lock Key

     

    Play notes by pressing keys on your computer keyboard

     

    If you only get single notes (pretty certain you will) then you know it's your KR-11 and either it's settings or the trype of preset you are playing on it... that is the cause of the problem...

  • joefromgreensburg Level 1 Level 1 (0 points)

    Ok you are right it isn't logic Pro 9 making double notes it has to be my MIDI controller (KR-11)

     

    So what do you mean by split layer preset?

  • The Art Of Sound Level 6 Level 6 (10,115 points)

    Some of the presets on the KR-11 utilize two or more sounds at the same time and it could well be that the preset you are using is outputting two or more notes for every one you play be it in split mode or layer mode.

     

    Try using different presets on the KR-11 and see if that changes things.... and also try playing notes together in just one part of the keyboard (to test for split mode issues)

  • joefromgreensburg Level 1 Level 1 (0 points)

    I am not using split layers, I can't even use my presets with local control off would you like a screen shot of the event list in logic pro or something?

  • The Art Of Sound Level 6 Level 6 (10,115 points)

    Yes please... that will identify the midi notes and channels that are being sent

     

    You say you can't use presets with Local Off.. Did you create an External Midi Instrument track in Logic to do?

     

    Also...

     

    When using a Software Instrument track... (so you are not listening to or using sounds from your KR11 and turning off Local Control..) selecting a software Inastrument... and playing on your Keyboard, do you get doubled notes in the Midi track you record?

  • joefromgreensburg Level 1 Level 1 (0 points)

    Screen Shot 2013-02-03 at 3.14.21 PM.png

    I get double notes in the midi track, the first 3 notes are the notes I played which are C, D sharp, and G, the last 2 are notes that are played after I release of my fingers off the 3 notes! There all from channel 1 though?

     

    And nevermind about not being able to used presets I was messing up something there.

  • The Art Of Sound Level 6 Level 6 (10,115 points)

    Its interesting that both the 'echo' notes are playing at exactly 64 Vel... and yes, they are all on Midi Ch 1... It still looks like they are being generated by your keyboard for some unknown reason.

     

    Anyhow, what happened when you changed presets? Did it make any difference?

     

    Also, can you do another screen shot of exactly the same thing but this time click on the "Additional Info' button so we can see everything coming from your keyboard...

     

    Also, can you double check your KR 11 is in "whole' mode and not in any other mode? (See section 6.2 of KR 11 user guide)  and...  make sure things like "Musical Intelligence" are turned off...

  • joefromgreensburg Level 1 Level 1 (0 points)

    No changing the presets didn't make a difference :/

     

    Screen Shot 2013-02-03 at 4.39.37 PM.png

    My Piano is in "Whole mode" but where do I turn music intelligence off? do you mean melody intelligence?

Previous 1 2 Next