Previous 1 2 Next 15 Replies Latest reply: Feb 3, 2013 2:45 PM by Mrsned
Mrsned Level 1 (0 points)

I need help!!


I have both an iMac and a Macbook Air, I think they are both 2009 if memory serves.


at first it was just the mabook, but now the ac has stated too. When I open iPhoto it says it has found inconsistencies and needs to repair the library, which then takes a few minutes, then as soon as I go into my facebooks ection to share photos straight to facebook it crashes and i get the "send error report" box.


I have checked for software update, but I have no idea what to try next. it's rendering iPhoto totally useless because it crashes the second I open it!!


Somebody help??!!

iPhone 4S, Mac OS X (10.7.2)
  • Old Toad Level 10 (135,314 points)

    Post the first 50 lines of the crash report and the lines for the Thread that crashed (if it's not Thread 0).


    Also try this:  launch iPhoto with the Option key held down and try to create a new, test library.  If you can import some photos and use it a couple of times to check to see if the same problem persists.



  • Mrsned Level 1 (0 points)

    Process:         iPhoto [583]

    Path:            /Applications/


    Version:         9.4.2 (9.4.2)

    Build Info:      iPhotoProject-710042000000000~1

    Code Type:       X86 (Native)

    Parent Process:  launchd [123]



    Date/Time:       2013-02-03 18:34:08.948 +0000

    OS Version:      Mac OS X 10.7.5 (11G63)

    Report Version:  9



    Interval Since Last Report:          4272 sec

    Crashes Since Last Report:           15

    Per-App Interval Since Last Report:  1697 sec

    Per-App Crashes Since Last Report:   15

    Anonymous UUID:                      2BCFC40C-EC34-4B1B-AB85-8C7CE5ED8916



    Crashed Thread:  31



    Exception Type:  EXC_BAD_ACCESS (SIGBUS)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000010



    VM Regions Near 0x10:

    --> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Applications/

        VM_ALLOCATE            0000000000001000-000000000003c000 [  236K] ---/--- SM=NUL 



    Application Specific Information:

    objc[583]: garbage collection is OFF

  • Mrsned Level 1 (0 points)

    Thread 31 crashed with X86 Thread State (32-bit):

      eax: 0x00000008  ebx: 0x7a469970  ecx: 0x7e236f14  edx: 0xd2015380

      edi: 0xac07def0  esi: 0x7a469978  ebp: 0xb1e4ab18  esp: 0xb1e4aaf0

       ss: 0x00000023  efl: 0x00010286  eip: 0x9072e0e6   cs: 0x0000001b

       ds: 0x00000023   es: 0x00000023   fs: 0x00000023   gs: 0x0000000f

      cr2: 0x00000010

    Logical CPU: 1

  • Mrsned Level 1 (0 points)

    Thanks Old Toad, are those the right sections?


    On the Macbook, i have tried, (in order) all four of the reapir library functions when you hold down the alt and apple keys  to open iphoto, if that smakes sense, none of them have fixed the problem on the macbook, even the rebuild database, hence why I moved onot my husbands imac for my photos, but I've yet to try any of the options on the iMac, or trying a new database.

  • Mrsned Level 1 (0 points)

    Hmm,, just created a new library, went to import some photo's to test it, and couldn't access my old iphoto library to import them. Clicked on events, photos, albums, etc all came up blank with no files showing to select to import.


    Ohhh, I am useless at this!!!

  • Old Toad Level 10 (135,314 points)

    You can't access the other library from the new library. Open the old library in the Finder as shown in this screenshot:



    Go into the Masters folder, select a subfolder and COPY (Option-drag) it to the Desktop.  Then drag that folder onto the iPhoto icon in the Dock.


    If the new library works OK the old library is the culprit.  If that's the case  Apply the two fixes below in order as needed: 


    Fix #1


    Launch iPhoto with the Command+Option keys held down and rebuild the library.




    Since only one option can be run at a time start with Option #3, followed by #4 and then #1 as needed.


    Fix #2


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


    1 - download iPhoto Library Manager and launch.


    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.


    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.


    4 - In the next  window name the new library and select the location you want it to be placed.


    5 - Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

  • Mrsned Level 1 (0 points)

    Sorry I'm totally lost, WHen I open iphoto as shown above and selevt show package contents like in the picture, i literally get a file in finder called contents??


    WHere should I be looking for the masters file?

  • Mrsned Level 1 (0 points)

    Is it anything to do with using iPhoto to upload pictures to facebook? Cos I just tried to upload a pic to fb in the new library and it crashed iPhoto again.

  • Old Toad Level 10 (135,314 points)

    Yes.  I don't know what  the solution is but many have reported on the same problem.  The workaround seems to be to export the photos to a folder on the Desktop and upload to FB via your browser.

  • Old Toad Level 10 (135,314 points)

    WHere should I be looking for the masters file?

    Inside the iPhoto Library package which is in the Pictures folder.


    As I posted previously open the old library in the Finder as shown in this screenshot:



    Go into the Masters folder, select a subfolder and COPY (Option-drag) it to the Desktop.  Then drag that folder onto the iPhoto icon in the Dock.

  • Mrsned Level 1 (0 points)

    Thankyou, I've used the iPhoto manager as you suggested but my hard drive is now full, half way through the creating process, what can I do??

  • Old Toad Level 10 (135,314 points)

    It's strongly recommended to have a minimum of 10 GB free space (20 GB if using iDVD) for optimal system and application performance.  If you get down in the 1-2 GB range you could be in serious trouble.


    Without backup strategy you're sure to lose your files. There are only two types of computers:  those that have crashed and burned and those that will.


    An easy solution is to get an external HD and use Time Machine back it up. And, if you boot drive is filling up a second EHD to store seldom used files, clearing up your boot drive.

  • Mrsned Level 1 (0 points)

    Thankyou again!


    I have a to shiva 1TB EHD that I use time machine to back up to. I'm not sure how to eat around the problem that until I have the new Database in place, i cant delete the old one, but I don't have enough disk space to create the rebuilt library.


    Is it possible/easy to say, move my iTunes to the EHD until I know the new iPhoto at abase is fixed? Does that make sense?

  • Mrsned Level 1 (0 points)

    Btw, I removed the Hal rebuilt library as I didn't tank it safe to leave the MacBook with no free disk space for long, and now I have 29gb free out of 250. Enough to function normally, but not enough to compete the new library. Just so u know, my old iPhoto library was 79gb.

Previous 1 2 Next