2 Replies Latest reply: Feb 3, 2013 4:36 PM by Jongware
ilyasyetisken Level 1 Level 1 (0 points)

ios 4.2.1 and 4.3 upgrade software is no longer enough


iPhone 3G, iOS 4.2