4 Replies Latest reply: Feb 3, 2013 9:39 PM by MadMacs0
harry3232007 Level 1 Level 1 (110 points)

What version of Java do I need? I am running Mac OSX 10.6.3 on a MacPro 8 Core. I have downloaded Java Updates 5, 6 and 12 but they won't install. Can anyone offer suggestions?

 

Many thanks, Harry.

  • ds store Level 7 Level 7 (30,315 points)

    Run Software Update under the Apple Menu, it will also update you to 10.6.8 with many security fixes and fixed Java 6 (only for 10.6)

     

    See

     

    Java on Mac's information

  • harry3232007 Level 1 Level 1 (110 points)

    Thank you for the reply.

     

    I don't want to update from 10.6.3 because I am running Final Cut Pro 6.0.5 and my system is stable. Updating my system to 10.6.8 brings with it the necessity to update Pro Apps and I end up in a mess when I am editing certain Hi-Def codecs.

     

    So I still need a Java version for my Snow Leopard version 10.6.3 and would appreciate any advice.

     

    Again, thank you for the response.

     

    Let me know if you have any further thoughts, please.

     

    Harry.

  • ds store Level 7 Level 7 (30,315 points)

    Disable Java (not Javascript) in all your web browsers preferences, that's the attack vector, via java web pages applets.

     

     

     

    There is also Java 6 on OS X (10.6) itself already (comes installed) via the Java Preferences in Applications/Utilities folder, leave this on for Java based programs your using.

     

    10.6 can't use Java 7 and Oracle is dropping support for Java 6 this month.

     

    Since your not going to use Java 6 online, then your Java programs should work as long as you don't update.

     

     

    Don't use Safari online as it hasn't been updated for 10.6 (10.7+ has Safari 6) use Firefox as it does get updates.

  • MadMacs0 Level 5 Level 5 (4,605 points)

    harry3232007 wrote:

     

    Thank you for the reply.

     

    I don't want to update from 10.6.3 because I am running Final Cut Pro 6.0.5 and my system is stable. Updating my system to 10.6.8 brings with it the necessity to update Pro Apps and I end up in a mess when I am editing certain Hi-Def codecs.

    Then you will not be able to upgrade to a safe version of Java 6 beyond what you have now. You are using a very unsafe system, so I would make certain it never accesses the Internet or any un-trusted networks.