Previous 1 2 3 4 Next 51 Replies Latest reply: May 6, 2014 10:30 PM by DJVH
Gweggie Boy Level 1 (0 points)

I have had my MBP for just over 3 months now!  Yes, I made the switch and up until now I have been quite happy.


I now have my Time Capsule, Apple TV running and am generally getting used to life as a Mac user.............even bought Aperture and loaded all the family photos.  Now time to make some Travel movies.


I have been working on a particular IMovie project for a few weeks now.  Size is 365MB.  Yesterday I closed IMovie and when accessing later that project is not available in the Project Library window.  It does appear in the IMovie Projects folder but I cannot open it.  I have copied the file to DVD just in case.  All up I have 4 Projects, the other 3 are practice files, smaller but they do appear in the Project Library.


I have scoured the bulletin boards and tried many suggested fixes to no avail.  Main suggestion was to remove the following files from Library/Preferences



However, this did not sort out my problem.  In the end I put back the original files.


Does anyone have a straightforward fix for my problem or is this one of those ongoing issues that that needs Apple's attention. 


After all the file is there with the others.  They are available.


I realise that I can restore from Time Capsule but I am missing the last three days thanks to 'drop out'.



iMovie '11, OS X Mountain Lion (10.8.2), MBP
  • John Cogdell Level 5 (4,605 points)

    That's very strange. I've had exactly the same problem. See my first post in the following thread for more details:



    Sorry I can't help solve this. It's very frustrating to find, after closing iMovie, that a project has gone missing from the Project Library (although it's still listed in the Finder).


    I'm beginning to think that an update to either iMovie or Mountain Lion may be the culprit. I've been using iMovie in all its iterations since 2001 and haven't seen this problem before (although the Events/Projects style only started with iMovie '08 of course).



  • Gweggie Boy Level 1 (0 points)

    Thanks for your comments John.


    Yes, considering we have an ongoing 'glich' within an Apple program with no obvious solution, we should be able to direct it straight to an Apple rep.  I will peruse this possibility when I get a moment.


    In the meantime, I have been trying the odd thing or two without success and finally gave up and restored the most previous file from my Time machine.  Worked a far!


    In my endeavours, I renamed some IMovie Projects in Finder - IMovie recognised these when subseqeuntly started, change of name and all.  My unable to open file is obviously there in its entirity, size is the same, it can be replaced by other backups, can be exported and burned to a disc etc etc.  Is it possible that IMovie just does not recognize it anymore, has the extension changed or format altered or whatever?  I am no expert and especially not with a Mac!!!


    The fix for this will probably turn out to be simple/ why doesn't Apple comment and/or address it????



  • John Cogdell Level 5 (4,605 points)

    Gweggie Boy wrote:


    Yes, considering we have an ongoing 'glich' within an Apple program with no obvious solution, we should be able to direct it straight to an Apple rep.  I will peruse this possibility when I get a moment.

    You can report the problem by providing feedback to Apple. In the iMovie app, from the menu select iMovie > Provide iMovie Feedback. This will take you to an Apple page where you can complete a form and submit it to Apple.


    The fix for this will probably turn out to be simple/ why doesn't Apple comment and/or address it????

    Other than the forum moderators, Apple doesn't normally monitor these forums, nor make comments on posts. So, it's up to us to report the problem to them directly (using the feedback form mentioned above).


    As the problem has affected me just the one time (touch wood), I haven't bothered to report it as yet. But, after seeing your posts on this, I'm now reconsidering that. Something must be triggering it. My system is in pretty good shape, so I'm guessing it must be a glitch of some sort, either in Mountain Lion or in the iMovie app itself. Perhaps it's a 3rd party app causing the problem? It doesn't give us much confidence now, in that we may start worrying about losing other projects.


    A good practice is to duplicate the project from time to time (something I'll be doing more of), although Time Machine backups also provide the necessary security. To duplicate, in Project Library view (where all the projects are listed) click on the project name so that it is highlighted, then select File > Duplicate Project. Alternatively, right-click (or Control-click) on the project name and select Duplicate Project from the pop-up menu. Of course, you may already know this. Duplicating probably won't guarantee that the copy will not also disappear from the Project Library, but is worth doing anyway.


    As I mentioned in the post I linked to earlier, when the problem arose with my iMovie project I was using ProRes 422 clips I had imported from a Final Cut Pro X Event. My immediate thought was that ProRes 422 had caused the problem. But this of course may have been coincidental - reinforced now by your experience, where you are probably working with Apple Intermediate Codec (AIC) clips.


    Anyway, glad to hear that you've recovered your project through Time Machine. Unfortunately, I had to start from scratch as I had Time Machine turned off during my editing sessions (that's a story for another day).



  • Gweggie Boy Level 1 (0 points)

    Thanks again for your comments.


    I have reported the issue via Feedback as I will hold my breath!


    Let you know if I hear anything.


    Thanks again.



  • John Cogdell Level 5 (4,605 points)

    Thanks for reporting this issue to Apple Greg. I will be doing the same as soon as I get a chance (been a bit caught up with things lately).


    Did you see that another member here has posted on the very same issue? Here's a link to the thread:


    Strange things are happening!



  • Gweggie Boy Level 1 (0 points)

    Yesterday morning started IMovie, and you guessed it, same problem with the same file. 


    I am wiser now so it is my policy to leave IMovie open while working on the file and when I take a break I execute a Back Up Now on Time Machine.  I also do this just prior to closing IMovie.  Just in case..........


    This morning the file does show in the Project Library inits entirity!


    I suppose I will continue to do this until I finalize or a fix is provided.


    I will report again to Apple then.


    Good Luck



  • BranonC Level 1 (0 points)

    Just had the same exact issue yesterday, so I'm obviously disappointed to discover this seems to be a real problem and not just a user-error on my part.  Strangely, my "lost" project was a file that I hadn't touched for months... 


    Has anybody heard back yet from Apple Support?  And since I've never been through the process, how likely is it that Apple will respond at all (and when)?  I'm in the truly unfortunate position of having no recent backup for this project file (my own error re: automated backup settings), and it also happens to be something in which I invested almost 6 months of work.  Fingers crossed that a fix is on the way...



  • Gweggie Boy Level 1 (0 points)

    Feel for you Branon..............just hope you have some sort of back up available!


    I have not heard from Apple.  I have no idea when and if I will.  I do hope they give our situation some attention though.


    Given the expanding prevalence of this problem, we can only hope that a fix will occur soon.


    I will hold my breath!



  • kraila Level 1 (0 points)

    This just happened to me while I was nearly done with a project I need to finish tonight. It's incredibly frustrating. Same as you, trashing preferences didn't work. Adding/adjusting the extension as suggested in some other threads also didn't work. I can open iMovie but the project doesn't show in the library. It's in the folder but doesn't have a proper icon.

  • Gweggie Boy Level 1 (0 points)

    I have today copied this full discussion to Apple vie Provide IMovie Feedback under the heading Ongoing Bug Needing Attention.


    I have also pointed out that it is an ongoing problem being experienced by many and is costing those people a lot of time and effort.  At the least I asked for a direction on how to recover/open those files we are unable to access.


    Apple Support where are you?????

  • John Cogdell Level 5 (4,605 points)

    Two others here have posted on this same issue:



    Thanks for your input on this Greg.



  • SharonLJ Level 1 (0 points)

    I am having the exact same problem. I was working on a project for the past few days. I saved and quit about 5:30 last night, and I have not been able to open it since. I have a done a number of things:


    -- used disk utility to repair permissions

    -- moved all the other imovie projects out of the project folder and onto a flash drive

    -- tried to open the desired Imovie project on a different computer

    -- add .rcproject extension to the project file itself

    -- Looked to delete the following files from my library/preference folder but couldn't find them:



    nothing has worked. Help.

  • Gweggie Boy Level 1 (0 points)

    Hi SharonLJ


    I am to this day not aware of any fix for this!!


    I hope you can restore from a backup, otherwise you will probably have to start again.  Makes Time Capsule a worthy investment.


    Good luck.



  • betaneptune Level 1 (0 points)

    Fascinating. I cannot imagine what it could be.


    What happens when you try to open it?


    Did you try right-clicking and clicking Open With?


    What version of iMovie are you running?


    What do you see when you run the Get Info command and compare it to others that open fine?


    How can you export it to DVD if you can't even open it?



Previous 1 2 3 4 Next