Previous 1 2 3 4 Next 53 Replies Latest reply: Jan 25, 2014 2:02 PM by amThankful
Angela1996 Level 1 Level 1 (0 points)

Hi, the shortcut won't launch so tried from IE but still nothing.  Looked in Program Files and the doesn't seem to be a .exe file?

Not sure what to do as I don't want to have to re-create whole library.  HELP.....

  • polydorus Level 6 Level 6 (11,950 points)

    Do you get an error message when you try to launch iTunes, if so give it in full.

     

    iTunes.exe should be in c:\program files\itunes in 32 bit windows or c:\program files (x86) for 64 bit windows.

     

    Could you confirm that it is indeed missing and also which version of windows you are using.

     

    If it is missing try going into Control Panel>>Programs and Features.

    If you can find iTunes listed there, try selecting repair.

     

    What happens if you do that? If it doesn't work give the error message in full.

  • Angela1996 Level 1 Level 1 (0 points)

    Hi, there's no error message, icon just goes around for a second then nothing.

    Can't see any .exe but can't add screen shot for you to see.

    I'm using Vista.

    Tried the repair tool but nothing has changed?

  • polydorus Level 6 Level 6 (11,950 points)

    I am struggling to get a clear picture of what is going on.

    Did the repair go through normally but it did solve your problem or something else?

     

    Do you 32 bit or 64 bit vista?

     

     

    I would like to ignore the missing exe for the moment and try something quick that can cause error message free launch failure.

    Try updating to the latest quicktime.

    http://www.apple.com/quicktime/download/win.html

     

    I think it's worth a go before going into something more complicated.

     

    My iTunes folder in c:\Program files(x86)\itunes looks like this (I have 64 bit windows 7)

     

    itunes folder.jpg

    If you want to post screenshots here is how:

    Posting a screenshot

    http://windows.microsoft.com/en-GB/windows-xp/help/setup/take-a-screen-shot

     

    Click in the window you want to copy.

    Press ALT+PrtScn

    Open Paint (Start > All Programs > Accessories > Paint

    Paste into paint (Ctrl+V)

    Save the image. File>>Save As

    Click on the little camera icon above the forum edit window to upload the image.

  • Angela1996 Level 1 Level 1 (0 points)

    Sorry about the vague answers just not sure what I'm doing!

    I've done the Quicktime install and it came up as repair or remove - so I've done repair.  No different to above.

    Tried to do upload but I don't have a paint option under Accessories......

     

    PS How do I tell if it's 32 or 64?

     

    Message was edited by: Angela1996

  • polydorus Level 6 Level 6 (11,950 points)

    Intended that you install a new version of quicktime not repair.

     

    Using an old version of quicktime with the new iTunes can cause error message free launch failure.

  • Angela1996 Level 1 Level 1 (0 points)

    The link didn't give me the option do you want me to remove and then install?

  • polydorus Level 6 Level 6 (11,950 points)

    OK, I misunderstood, so if you get that message your probably have the latest Quicktime.

     

    I am disappearing until tomorrow now.

     

    In the meantime, I think it would be wise for you to check for malware have you seem to have something odd going on.

     

    I suggest you download the free version of malwarebytes and run a full scan:

    http://www.malwarebytes.org/

     

    If you are clear of malware

     

    Try a complete removal of iTunes and related programs using this method:

    http://support.apple.com/kb/HT1923

     

    If you get any errors we will have to deal with that tomorrow.

     

    I the uninstall goes OK, Restart your PC and install iTunes:

    http://www.apple.com/itunes/download/

     

    And Quicktime if you want it.

    http://www.apple.com/quicktime/download/win.html

  • Angela1996 Level 1 Level 1 (0 points)

    Hi there, I followed the instructions above to the letter and in the right order and iTunes still won't launch.  Still the same a quick whirl of the pointer and then nothing.

    When I ran the scan there were 37 things detected, 3 were highlighted so I selected to remove them, and left the others.

    When I checked that everything had 'uninstalled', I think under Apple Support Device there were loads of files left so I deleted them.  Except two wouldn't let me, it said I didn't have permission.

    What can I do next apart from run away screaming!!!

  • polydorus Level 6 Level 6 (11,950 points)

    If you found stuff with malware bytes, you need to fix it before you try to fix iTunes as maware can certainly interfere with iTunes.

     

    I can't help you with malware removal, but if there is stuff that malwarebytes can't fix, there is a malwarebytes forum and you should get good help there. You may even need other tools to fix the problem, but they will advise.

    http://forums.malwarebytes.org/index.php?s=2ff6d4d990887001d768537c9b8ff332&show forum=7

  • Angela1996 Level 1 Level 1 (0 points)

    Hi, I've done all of the above again, including removing all the files that showed up in the Malware log. 

    When I checked to see that all of the iTunes things had been removed there were still 2 files that wouldn't let me remove them:

    1.     Internet Services

    2.      Mobile Device Support

     

    They had things like APLZOD.resource, icloud.resource, shellstream.resource plus a load of .dll files.

    Re-installed iTunes and nothing has changed....  Any further ideas/suggestions please?

  • Jim Erlach Level 2 Level 2 (360 points)

    Let's see if I can help debug this:

     

    If you were not able to remove f"Mobile Device Support" then there may still be old files in there.

     

    What is the create date of,

    Program Files/Common Files/Apple/Mobile Device Support

     

    From the list below, what Task Manager processes are running when iTunes is NOT running?

    Make sure “Show Process from all users” is checked

     

    AppleMobileDeviceHelper.exe

    AppleMobileDeviceService.exe

    APSDaemon.exe

    ATH.exe

    distnoted.exe

    iPodService.exe

    iTunes.exe

    ItunesHelper.exe

    mDNSResponder.exe

    SyncServer.exe

  • Angela1996 Level 1 Level 1 (0 points)

    Hi there

     

    The top level folders are all 06/02/2013 (from re-install yesterday?) except one OutMMe32.resources which is 24/10/11, dates of files under these folders vary.

     

    In Windows Task Manager, under the processes tab, the ones that I have added a comment to are there with the CPU figure and memory.

     

    AppleMobileDeviceHelper.exe

    AppleMobileDeviceService.exe - In list CPU: 00 - 644k

    APSDaemon.exe

    ATH.exe

    distnoted.exe

    iPodService.exe - In list CPU:00 - 820k

    iTunes.exe

    ItunesHelper.exe -  In list CPU:00 - 1100k

    mDNSResponder.exe - In list CPU:00 - 600k

    SyncServer.exe

  • polydorus Level 6 Level 6 (11,950 points)

    Hi Angela

    A few things first.

    DO you get a clean bill of health if you run a malwarebytes scan now? In an earlier post, I think you said that there were things malwarebytes could not remove. It is essential that any malware is cleared out before trying to get iTunes working.

     

    As you are having trouble deleting files It would be a good idea to run a full disk check, which unfortunately is quite slow. Windows may not be able to delete a damaged file.

    http://windows.microsoft.com/en-us/windows-vista/Check-your-hard-disk-for-errors

     

    Does that come up clean or were there errors and if so were they fixed?

     

    When you uninstall all the iTunes related programs, do the uninstalls go through without any errors?

     

    After you uninstall all the iTunes related programs, try restarting your PC before trying to delete the files and folders, hopefully this will make sure that none of the background programs are still running when you do the deleting. If a file is in use it can't be deleted.

     

    If you are unable to delete a folder go into it and find out the file that can't be deleted, what is the error message. Sometimes a corrupt file can't be fixed by the disk check and we have to work round the problem in another way.

     

    Things do not seem to be straight forward in your case so we have to try to work through this in a systematic way. We need a system free of malware and damged files and a properly completed unistall before trying another reinstall of iTunes.

     

    If you google: missing iTunes.exe, you will see that it is a murky problem.

  • Angela1996 Level 1 Level 1 (0 points)

    Will give it a go!  Will try anything to get it sorted!!

Previous 1 2 3 4 Next