3 Replies Latest reply: Feb 24, 2013 7:18 AM by apbeckman
ccvb Level 1 Level 1

I just updated my iPhone 4s to ios 6.1.  I am a verizon customer but after the update my phone's carrier is set to Sprint 14.0 and verizon has no idea how to fix it.  I assume this is a software issue.  Anyone else having these issues?

iPhone 4S, iOS 6.1
  • apbeckman Level 1 Level 1

    Someone else, finally! I have this problem as well and I have no idea what to do. I think my phone was originally locked to Sprint, and the update restored its factory network settings. I had gotten this phone as a replacement for another 4S from the apple store, and I don't know if they would be obligated to replace this one, as there's nothing technically wrong with the phone, it just doesn't work on verizon's network.

  • T3z2 Level 1 Level 1

    i have the same problem too did an update to 6.1.2 and now my phone says its locked to Virgin. Originally it was locked to Verizon. I guess apple update servers have a glitch in them which fails to update proper carrier settings. Please advice on whether you got a replacement?

  • apbeckman Level 1 Level 1

    I drove up to the apple store, and got a replacement 4S from them, which worked fine. That is, it worked fine until I drove home, and updated the software. It went back to being stuck on the activation screen, and after driving to and from the apple store once more, a guy at the Genius bar determined that at some point in the replacement process(the first time I exchanged a phone) an Apple technician had entered a serial number incorrectly. He filed an escalation with Engineering, and I went back and forth with them for a little over a week. They wanted the serial number from a phone I didn't have anymore, and when I finally figured out how to get it(from my backup records on iTunes), they said they had no record of that phone ever being linked to Verizon. The admins at the Apple store that I had been communicating with eventually gave up on Engineering and ordered me a brand new iPhone 5(hey, at least I got a free upgrade out of it, right?), which I drove up to the Apple store a final time to retrieve this past Tuesday. My issue started on February 4th, and was finally resolved on the 19th, after much trial and error. I don't quite know if your issue is the exact same as mine, or if you'd be able to resolve it by providing the correct serial number to them, but my advice is to go to the Apple store and tell them literally everything you know about the issue, and that it hasn't been solved by simply restoring or restarting your phone. Hope this helps, and best of luck! I was without a phone for half a month because of this, so I sincerely hope your experience will be faster.