Skip navigation

10. games i want to get are runnung on 10.6 or higher ...should i buy this unit and if so what can ido to boast the unit ??

423 Views 3 Replies Latest reply: Feb 6, 2013 12:38 PM by BDAqua RSS
adrianfrombasildon Calculating status...
Currently Being Moderated
Feb 4, 2013 9:44 AM

i have just put a deposit on a mac desktop 1.8ghz  3-ram 160hd mac os 10.5 leopard ..im worryied coz its runing on 1.8gh and the games i want run on 10.6 or more can anyone give me advise on how to deal with this please!!???? HELP

Mac Pro, Mac OS X (10.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.