14 Replies Latest reply: Jun 15, 2015 12:33 PM by Avallennek Branched to a new discussion.
Majicmeow Level 1 (0 points)

Hey guys/gals,


I have an issue with a Western Digital "My Book Live 2TB" NAS drive that I am trying to setup as a Time Machine backup. The My Disk Live is connected to my Airport Extreme and my Macs are connected via Wifi on 5ghz. The Western Digital forums are FULL of people having the same problem as me but there seems to be a general lack of knowledge regarding OSX and no fixes have come to light.


First, the good part: The drive supports Time Machine out of the box and the Time Machine system preference panel sees the drive and accepts it as a valid backup drive.


Now, the ugly part: For a 350gb backup, Time Machine states that the backup will be done in approx 3 days. When I use Activity Monitor to check the copy rates when on Wifi, they peak at about 5mb/s (understandable) but they AVERAGE under 100kb/s. When connected to my APE with an ethernet cable, my speeds peak at aroun 10-12mb/s but still, they average a snail like 100-200kb/s.


Over the course of 24 hours, I was able to copy a whole 40gb's when connected directly to the APE with the ethernet cable.


The funny part is this: When copying a normal file or folder from my MBP to the MDL over Wifi, the speed holds steady at approx 5mb/s through the whole transfer. I can copy a 10gb file in approx 30min. When connected via ethernet directly to my APE, the speeds for a normal file transfer to the MBL are approx 10-12mb/s at a constant rate. When reading files off either of my MDL's, speeds are generally quite good as well and allow for streaming of HD content without inturuption.


I have tried creating a Time Machine Backup on my other Mybook Live with identical firmware and the result is the same. I am assuming, simply because copy speeds are very consistant and fast (relativly speaking) when copying files normally, that the issue resides within Time Machine itself which leads to the question: Why does OS X 10.8.2 copy files at a decent speed over both Wifi and ethernet, yet when using Time Machine, copying to the SAME drive, I'm looking at the better part of a week to get my backup done.


Also worth noting, my Time Machine backups to an external USB drive are faultless and fast. No issues what so ever.


For those who are willing to help me out, here are some details:


-Macbook Pro 13" (mid 2010) with 10.8.2

-Apple Airport Extreme 5th Gen with firmware 7.6.1 connected with 802.11n 5ghz.

-Western Digital My Book Live with firmware 02.32.05-046


Any help that is offered is very much appreciated! Thank you in advance,



MacBook Pro (13-inch Mid 2010), OS X Mountain Lion (10.8.2)
  • LogicalAudio Level 1 (5 points)

    I believe it's because you are logging into this as GUEST

    **Don't log in as guest


    try again and

    log into the WD DRIVE in TIME MACHINE

    as user: admin


    Hope this helps ya out.

    report back if it does

  • Majicmeow Level 1 (0 points)

    I figured that since WD instructed to login as "guest", that was the way to do it...


    anyways, I deleted the Time Machine share <sob, so many hours of work!> and started over, creating a new share, reselecting the drive in the Time Machine prefs and starting a new backup.


    The copy speed, as of right now (approx 15min in) are averaging about 4.5mb/s, which is considerably faster on average than I was hitting before. The speeds still dip into the kb/s range for a second or two at a time, but otherwise stay pretty decent.


    Let's see if those speeds hold over night or if they are going to taper off into the kb/s range by the morning.


    Thanks for the heads up, I'll update this page if things change



  • LogicalAudio Level 1 (5 points)

    Good, you needed to delete the time machine share that was created as GUEST

    and start fresh.


    If you are using a ethernet cable (cat 5e) then you are going 1GIG ethernet both ways.

    Which is cool.




    Your drive is the bottle neck.  8-)


    I should explain, since the drive can only read/write about 40-50MB/sec

    (download the BLACKMAGIC disk speed test mac app to test your disk speeds)


    You could  be pushing at least 100+ megabytes per second with gigabit ethernet with an SSD drive.

    Next move would be getting one of those SSD's, (unless you have one already)

  • Majicmeow Level 1 (0 points)

    Well, things went well for about an hour... I managed to get 7.5gb backed up before the speeds dropped to the 100-400kb/s range again.


    I stopped the backup and restarted it again, but the speed remain below 2mb/s on average. See below for an idea of my speeds.


    I'm wondering if it has to do with the files that Time Machine is backing up? Does Time Machine copy smaller files at a slower rate due to the sheer number of them? I find it strange that Time Machine would do this, but I don't really have a better explaination?


    I'm going to try again overnight while connected via an ethernet cable and see what kind of transfer I get come morning.


    Thanks again for the help,




    (btw, no SSD's... trying to get this "simple solution" to work out of the box, like it should!)



    Screen Shot 2013-02-04 at 9.48.14 PM.png

  • Majicmeow Level 1 (0 points)

    Well, imagine that, the backup finished at approximatly 6am this morning. My peak speed over wifi (5ghz) was 15mb/s and, I imagine it was consistantly above 5mb/s to finish a 350gb backup before morning


    Thanks for the insight regarding the login on the WD drive, that seems to have fixed it



  • LogicalAudio Level 1 (5 points)

    Good to hear, it's all about having it backed up.

  • Rick Wall Level 1 (5 points)

    I had speed problems when first using a My Book Live too.  You can check the thread I started here for a few tips.




    I think my Time Machine backups are significantly slower than simply transfering to and from the drive, but they don't bother me.  I've used an Apple Time Capsule for 2 years, and it seems like the My Book backups just as quickly as the Time Capsule ever did so I would assume it's a Time Machine thing.  It does seem like large backups (350 GB etc) back up much faster than the regular backups fo actually.  I feel like some of my large backups would take days if they were going the same speed as regular backups.  Could it be that Time Machine monitors backup speed?  Perhaps in the case of an initial backup, Time Machine knows you can't wait days for that so it uses the maximum speed possible to backup, but it uses a much slower speed during small hourly backups so as not to hog too much speed or power or something.


    I'm pretty sure my Time Machine still connects to the My Book via the guest account so maybe I'll try logging in with the admin account.

  • Rick Wall Level 1 (5 points)

    Just to be totally clear, after doing everything mentioned on the thread I started, I've been very happy with Time Machine and My Book Live for over a month.

  • Charlie.Loxely Level 1 (0 points)

    Hi, All.

    I'm haviing a similar problem with speed using the 3T network drive, but it's not just the back-up rate, as I'm still loading the mass of data files from my iMAC. In hindsight I should have just purchased a direct drive, but for now I've got this one.



    a) I connected the ethernet cable DIRECTLY to my iMAC to transfer the bulk of my files to the drive. Since it's a direct transfer I didn't see the need to set up user profiles just yet and used 'Guest.' The iMAC is less than a year old and was built with a good & fast network card etc.

    b) The transfers are painfully slow, and any larger folders usually hang up Finder or stop before they're completed.

    c) On about 1/4 of my transfers the copy window indicates the files are moving (by item count and size estimate), but the estimated time keeps rising to an unbelievable estimate (2 hours for 700MG? Really?) If I leave them anyway they usually hang or stop before completion as well.)

    d) I found that by deleting any system files (ie DS_Store) I improved my success rate with problem folders (ie ones that hang, increase to unreasonable times or abort mid-transfer).

    e) Still some directories would not copy, and by moving all the subfolders individually I found it was always caused by one consistently sticky folder. I finally solved this issue by zipping the troublesome folders, so I strongly suspect it has something to do with MAC filetypes.

    f) The WORST part of the MyBookDrive is that even when there is no other activity on it, tasks that should be instantaneous take 15-45 seconds. For example, when you select any given sub-folder it takes up to 30 seconds just to display the contents. The lag means that simple tasks like renaming a file/folder using the double tap method can be impossible: You need to use 'Get Info,' and that can take up to 30 seconds to load. Moving files between folders can take up to a minute.

    g) I tried logging in as admin, but it wants a password. Since it's directly hooked up to my iMAC I tried my machine username here, but it didn't recognize me.


    Questions (please):

    1) Is anyone else experiencing the same lag with basic tasks?

    2) Has anyone got any insight into the hidden system files issue? (See d, above)

    3) How do I set up the users on this thing? Even when I unplug and replug it, it doesn't offer me a setup dialog. (WD support was worse than useless.)

    4) If I can't get this thing to speed up, can anyone recommend a solid & reasonably fast 3T external drive that won't break the bank? (under CA $225 would be good.)


    Thanks so much!


  • milaka99 Level 1 (0 points)

    I'm having this same problem now. Running 10.8.3, new MBL out of the box with updated firmware. First backup as GUEST took nearly 24 hours, wired (360GB). As I watch the incrementals running now, I'm seeing the speed as 30-100kb, which is not only slow but it's also bogging down my cpu. I'm willing to try the delete and run it as admin, but does this have to be done the same way if i'm backing up two macs to it on the same network, and can i log in with the same admin (which i changed the name/password when i set the MBL up)?


    also would you mind elaborating on why not to use guest, and how that affects the speeds of transfer? is it going to ask me for the user and password everytime it doesn an incremental backup? thanks in advance for any help you can send my way.

  • Pondini Level 8 (38,740 points)

    One of the problems with backing-up to a NAS is, it has it's own operating system, setup procedures, file/folder handling, etc., which neither Apple nor most of us helpers have access to or any experience with. 


    On an initial (ie, full) backup, or the first backup after an OSX upgrade, the backup will start rather slowly, if measured on a per-GB basis.  That's because of the complex structure of TM backups (see the tan box in How Time Machine works its Magic for details), so it must do a number of things for each file; and the first things backed-up are your Applications, Library, and System folders, which consist of an enormous number of mostly itty-bitty files.


    But the speeds shouldn't be anywhere near that slow.  If you're sure you've followed the maker's setup procedures properly, and the NAS is (or claims to be) compatible with the version of OSX you're running (some aren't), see #D2 in Time Machine - Troubleshooting for some other possible causes of slow backups.

  • michisoft Level 1 (0 points)

    Exact same issue here and great frustration, but I saw some light today.


         WD MyBook Live Duo 2TB (RAID) - connected by an ethernet cable to the cable modem router

         MBP 6,2 (2010) connected over WiFi, 5GHz

         OS X 10.7.5, 8GByte RAM, 500GByte HD

         Cable Modem Router CBN SVG6540E, Gbit ethernet.


    I always had this problem. Today, after not having backed up for more than a month, I was desperate but willing to spend the entire weekend and beyond, without using my laptop.


    Following some discussions online, yesterday I tested - via ssh/sftp - the transfer rate of my MBP to MyBook: it misteriously starts high ~10MByte/sec and then progressively decreases to 3-4MByte/sec.


    I launched the Timemachine (even tried the single-user mode reboot trick, although in single-user mode my MBP does not "see" the MyBook). After 36h, I decided to sit and observe the (extremely) slow transfer rate via the Activity Monitor (~kByte/sec).


    Out of desperation I followed the advice I found online (http://reviews.cnet.com/8301-13727_7-10447576-263.html): force kill the process named "finder" by means of the Activity Monitor.


    To my surprise and as described, the transfer speed immediately jumped to ~5-8Mbyte/sec. In ~30 mins the backup progressed, finishing, by 8 GByte, almost the same amount transferred over the past 36h !


    I note that after a while the finder process was re-launched automatically, but the transfer speed did not decreased. For some reason the TimeMachine restarted backing up another ~100Mbyte and again the transfer rate was low. Killing once more the finder did speed up again the transfer rate. For some reason the backup remained (apparently) hanging at 79MB out of 100MB for some time (~10mins). After that Timemachine said "Backup finishing" and it took another some time to go back to a quiet state.


    Hope it helps.

  • DaveB. Level 1 (0 points)

    QUITTING "FINDER" is the solution I found.


    For the past month I have been fighting with MyBookLive. I have not had a backup greater than 5% of my 900gig (MacBook Pro). I have done everything. Well I just found something that has worked for me. Open "Activity Monitor" and "Quit' Finder. My backup speeds have shot up from 10k/sec to 3.0meg/sec.


    (I am always logged in as "Guest" on the drive.)


    I do not know if my configuration is correct but I am not touching this until the backup is complete. What I did was to use a crossover Ethernet cable directly into the MyBookLive. I deleted the software and I reinstalled it. I think I might have made a slight error as the software told me that MyBookLive-01 is already in use, so I accepted its suggestion and I renamed it to MyBookLive-02. I think I should not have as now I will have to go in and delete the partial backup.


    Small thing: once you "Quit" Finder you will not immediately have the use of "Finder" Not big deal but, once you click on "Finder" it will reappear in Activity Monitor.  I watched my speeds and they did not seem to change once Finder was back, but just incase I "Quit" "Finder" again.  I am going to leave this running until tomorrow. 


    WOW, Since I'vve typed this there has been another 2gig backed up!!!!

  • Avallennek Level 1 (0 points)

    Thanks so much for this tip - in desperation trying to do a 350GB back up to MY BOOK I tried this trick - I stopped the Finder application in Activity Monitor and POW - the back up speed rocketed...