3 Replies Latest reply: Mar 9, 2013 12:56 AM by Luke Road
marikas Level 1 Level 1 (0 points)

have 10.5.8 and cannot open itunes becasue itunes requires quicktime 7.5.5 or later but canot download - reomoved qt but it says i have most recentsoftware in updates