9 Replies Latest reply: Feb 11, 2013 3:01 AM by Thanar
Thanar Level 2 Level 2 (290 points)



I've been using Time Machine for over 3 years now with no issues over the network; the destination being a 2TB external Seagate connected to another iMac connected through gigabit ethernet. Everything has been working flawlessly: Every hour Time Machine would MOUNT the sparseimage it created on the disk, BACKUP the data and UNMOUNT the disk image when finished.


Until I upgraded to Lion. The above process is still working per se, however it is PAINFULLY slow! A 50MB backup can take up to AN HOUR! Searching around on the net, advised that there could be an issue with Spotlight as well, however this is not the case for me, since Spotlight finished a new index in under 30 mins. Followed every tutorial I could find on the issue, to no avail..


I then upgraded to Mountain Lion with the hope that the issue will clear itself. Cleared my old backups, resetted Time Machine by erasing its .plist file, restarted my iMac just to make sure and connected Time Machine to the network share anew, creating a "sharing only" account on the host iMac, i.e. the one that has the external HD connected through USB. Still no luck.


I painfully realize that I still have the same issue. While backing up, network traffic is under 100KB, and activity monitor does not show any backupd or mds or any similar processes taking anything over 3% of CPU time.


What could be wrong?

OS X Mountain Lion (10.8.2)
  • Thanar Level 2 Level 2 (290 points)

    It's been stuck to "Preparing backup..." for at least two hours now, trying to create a new sparseimage on the network volume that's already reached 6.3MB in size!



  • Thanar Level 2 Level 2 (290 points)

    Ended with the creation of the disk image, couple of more hours went by on preparing, no network access or CPU intensive tasks on Activity Monitor, giving up on Time Machine for now!

  • Thanar Level 2 Level 2 (290 points)

    I finally decided to switch to using "tmutil setdestination" in order to change Time Machine's backup volume to the mounted volume that mounts by double-clicking the backups sparseimage through the Finder. That way, backups take place instantly.


    I still would like to use the "official" method to select my Time Machine destination, though...

  • Eric Root Level 8 Level 8 (41,185 points)
  • Thanar Level 2 Level 2 (290 points)

    Unfortunatelly, I have been trying numerous troubleshooting guides (these two included) with no luck over the last couple of weeks. I will be using Time Machine with the Volume as the backup destination which works fine, for now, hoping that this whole mess is a bug, to be found in some next OS update.


    The only thing I haven't tried yet is completely wipe the system HD and install ML from scratch. Haven't done such a clean install since Tiger!

  • Eric Root Level 8 Level 8 (41,185 points)



    What happens when you back up the iMac the Seagate drive is hooked to? Same behavior?


    Have you tried backing up from another account on the computer you are having problems with? Trying to determine if it could be account related.


    Can you hook up the backup drive direct to ethernet and see if you are having the same problem? Maybe having to go through the other computer is causing the problem?


    If you attach the Seagate drive to the computer you are having problems with, does it backup with the same problems?


    Since it worked before the Lion/Mountain Lion upgrade, it may be a bug. I have 4 NAS drives I back up to from Mountain Lion on two different computers, so maybe it would work if you installed a switch so you could hook the iMac direct and the Seagate drive direct to the ethernet.



    Just trying to narrow down the problem.

  • Thanar Level 2 Level 2 (290 points)

    Hello Eric, thanx for the sign in...


    The iMac the external HD is hooked to backs up with no issues whatsoever.

    I did try different accounts on both iMacs right now, and the issue seems the same.


    The drive cannot be hooked directly on ethernet, since it's a plain external HD, USB2 being its only connection method. It has to be hooked onto a host (be it a computer or a NAS, doesn't matter) in order to gain presence to the network.

  • Thanar Level 2 Level 2 (290 points)

    Hello again,


    I tried something new: I have an AFP-enabled NAS server on my network, so I thought I create a new backup there to test things out; the image was created in under 10 seconds, and in just 5 minutes 2GB of data had already been transferred! That said, looks like the issue lies within the host computer, i.e. the one that has the external HD hooked onto.


    Will try later with a friend's iMac who's on the same network and has an external HD plugged as well and see what happens...

  • Thanar Level 2 Level 2 (290 points)

    Hello again,


    Tries on the other iMac (also running 10.8.2) and things are exactly the same: Image creation takes almost half an hour, and copying crawls at under 1MB/min. While time machine image is mounted and Time Machine is "backing up", accessing ANY disk on the host Mac is VERY slow. Seems like something hogs up appleshare when Time Machine is in use. Mind you, there is insignificant network traffic as seen by Activity Monitor, as well as insignificant CPU usage while backing up.


    Stopping backup and using tmutil to set the Time Machine destination to the mounted image as mounted by Finder, solves the issue again, revving up Time Machine throughput to over 20MB/sec! There is also no issues acessing the other Mac as well, under this scenario.


    Up to this point, the only way I have managed to use Time Machine over a networked external HD is through the NAS server. Both configurations where I am using a Mac running 10.8.2 as a server of the external disk have failed with very low throughput while backing up. Something must be wrong in 10.8.2's afp when Time Machine is mounting the image by itself.


    I may need to remind you that I have been successfully backing up to the external HD for 4 years now; something broke a few months after the client iMac was upgraded to Lion and at the time when the host iMac was upgraded to Mountain Lion. Will try to locate a Mac running some later OS X version to do some more testing.


    Also reminding that I have used two distinctive iMacs and two external HD drives for my tests so far. The client iMac has remained the same, however 10.8.2 has been reinstalled on it a couple of times. Have also used an afp-enabled NAS server which worked fine with Time Machine.