9 Replies Latest reply: Mar 11, 2013 4:19 PM by lida_pap
CheHernandez Level 1 Level 1 (0 points)

Just upgraded my phone to iOS 6.1 and it has no sound, restarted lot of times, did restore from backup, reset settings and tried the dock with it sound came back but when i take it out the sound is gone again, what can i do? please help :/


iPhone 4S, iOS 6.1
  • Schnolld Level 1 Level 1 (0 points)

    I'm having a similar problem. I also have a 4S, just "upgraded" to 6.1, but my sound issues are limited New Mail and Text Messages. My phone still rings when a call comes in, and with most other apps I've tried. But I get no sound for text messages or mail.

     

    I've tried restoring, restarting, etc...

  • stopverabike Level 1 Level 1 (0 points)

    That Samsung Galaxy s3 is looking real good bout now....

  • CheHernandez Level 1 Level 1 (0 points)

    not really.. i saw how to fix it and the only way is with a jailbreak to do that.. so.. we are screwed

  • TheWeakLink Level 1 Level 1 (0 points)

    i may have found a work around. go to Settings---> Notifications ---> Messages or mail -----> then change the alert sound to something esle, let it play, then change it back to what you had originally. it seems to work for both my iPad and iPhone 5... can say why, it just does.

  • JeafGilbert Level 1 Level 1 (0 points)

    Mine is iPhone 4S (warranty is void). I'am having the same problem. Sometimes back to normal (after idle for a while), but not last. Turning off the phone raises back the issue.

     

    - On volume up/down button clicked: Ringer overlay is shown but not bars

    - No lock/unlock sound

    - No notification sound

    - It's ringing when receive phone call or set volume from Sound setting

    - After turned off, iPhone won't turn on unless plugged to charger

     

    I've done these:

    - Cleaned up charging port

    - Dryed the iPhone (hairdryer; below the sunlight) - just in case

    - Reset all settings

     

    I haven't restore the phone since I'm not sure if messages, mails, WhatsApp, LINE (etc) histories will back after synced from backup.

     

     

    I read that deleting com.apple.iapd.plist (Root>System>Library>LaunchDaemons) can fix this, but it needs jailbraking (iFile/iExplorer) which I don't want to. Furthermore, "Deleting the 'com.apple.iapd.plist' may effect the functioning of hardware accessories that go with various apps, such as FM transmitters and Nike accessories, etc." —wisso (https://discussions.apple.com/thread/3790682?start=45&tstart=0)

     

     

    I'm not sure if some apps crash with latest iOS update and cause this.

     

     

    I'm still looking for the right solution.

  • mystic black Level 1 Level 1 (0 points)

    i have already solve the problem..

    follow the step.

    1- lock skrin with power button

    2-wait for a minute

    3- double click home button..

    4- if u see the music sound slider hold it quickly (only if u see the slider, please be quick before the slider hide again)

    if u dont see the slider or it has been hide again, repeat step 1

    5- use other finger to touch play button.. then slide the sound left and right

    6- done your sound will be enable back..

    7- restart your phone to make sure the problem not coming back

     

     

    it work for my iphone 4s..tq

  • mystic black Level 1 Level 1 (0 points)

    this trick has been found by me today.. feel so happy when i can hear my phone sound back.. hehehe

  • jesterhawk Level 1 Level 1 (0 points)

    I have tried all the steps above and nothing works.  I get sound some times when I get calls but no sound ever on texts and hit or miss on other sounds.  Very frustrating.

  • lida_pap Level 1 Level 1 (0 points)

    Hey i had that problems and more. it worked for me the thing with the earphones but it didnt last long and i had to do it several times which kinda ruined the experience.

    Then one day i accidentaly left my I phone on a heater (radiator) for a couple of hours causing it to burn as **** and at first to show nothing and after 5-10 minutes it showed the overheating screen. When it finally coolled of (which was about 30 minutes and a lot of personal agony later) all the above problems were gone. I dont want to jinx it but its been 3 days and it still works fine.

    now i am NOT saying u should do that i am just saying what helped me...

    perhaps the overheating reboot is different from the one where u restart it.

     

    Good luck to the rest of u with the problems