9 Replies Latest reply: Feb 8, 2013 5:19 AM by Kilgore-Trout
JohnZonie Level 1 Level 1 (30 points)

3rd Gen iPad is now showing 3 - 6 icons for each book and, more problematically, most past purchases have changed to downloads from being storred on the iPad. A download attempt says "This device is already associated with an Apple ID" and did i want to transfer to the device Apple ID.


In the past, my wife and I used a common login for purchasing iStuff so that it would be available to both of us on our various iPads and iPhones. Now, it appears that no longer works. Is this a local problem perhaps with my iPad or has there been some kind of policy change?


Regardless of a policy change, the 3 - 6 icons per book appears to be a bug. Anyone else see this?

  • JimHdk Level 7 Level 7 (28,295 points)

    There is no policy change.


    Have you tried terminating and restarting iBooks?


    To terminate iBooks:


    1. Click the Home button

    2. Double-click the Home button to bring up the "recent Apps" tray at the bottom.

    3. Touch and hold on the iBooks icon until a "-" appears

    4. Touch the "-" on the iBooks App to terminate


    If that doesn't work you can try restarting or resetting your iPad?


    Restart: Press On/Off button until the Slide to Power Off slider appears, select Slide to Power Off and, after the iPad shuts down, then press the On/Off button until the Apple logo appears.


    Reset: Press the Home and On/Off buttons at the same time and hold them until the Apple logo appears (about 10 seconds). Ignore the "Slide to power off"

  • JohnZonie Level 1 Level 1 (30 points)

    Thanks for the suggestion. Just went through all the steps, including a complete restore from a backup, all to no avail. Before resetting, I backed up. I still get the device associated message. To compound matters, even though I had wifi sync enabled, the most recent backup was two months ago! When I tried to restore to that I lost all my apps This is going from bad to worst.


    I guess I have no choice but to start fresh. If anyone knows, the complete text of the error message is shown below:



    Assume the apple ID used for iCloud is 123@mac.com and the apple ID used for app store purchases is 456@comcast.net. Does anyone have any idea which apple ID is being referred to in this message?



  • Kilgore-Trout Level 7 Level 7 (30,065 points)

    The AppleID that will be unavailable for 90 days is the one that was currently in use. Your apps will not be deleted, and are still associated with account, but youwill not be able to login with that ID for updating them until the 90 day period is up.


    It is easy enough to use different ID s for different purposes, but switching back and forth on the itunes/App store presents some issues.

  • JohnZonie Level 1 Level 1 (30 points)

    I assume you are referring to the 456@comcast.net, that was used for the app store, correct? The bizarre thing is that this apple ID shows up in the app store and book store. So there is no different account ID per se. In other words, the message appears to be telling me to change the apple id from 456@comcast.net to 456@comcast.net.


    This makes no sense to me.

  • Kilgore-Trout Level 7 Level 7 (30,065 points)

    Perhaps you should try contacting iTunes support to get it sorted: http://www.apple.com/support/itunes/contact/

  • JohnZonie Level 1 Level 1 (30 points)

    Thanks for the link, James. Just did that. We'll see what happens...

  • JohnZonie Level 1 Level 1 (30 points)

    Well, it has been an interesting day. After not getting anything from iTunes support except a formulaic acknowledgement of the problem and a promise to "do our best to resolve the issue", I received no further communication from them. So, I trundled off to the local Apple store and the Genius bar. After initially saying that there should be only one iCloud Apple ID per purchase, even though the purchase was done on another ID, the comcast.net one in my example, we logged out of the mac.com iCloud account and miraculously were able to download the books purchased on the comcast ID. This download ability continued after logging back on to iCloud using the mac.com Apple ID. So all was good with iBooks download, except for all the missing applications!


    Oh, I didn't mention that, after the 6.1 upgrade and attempts to restore, all the previously installed applications and their attendant data(!) were gone! Despite many restore attempts, including one going back to November 2012, I was not able to restore the applications.


    Unfortunately I had relied on the integrity of the iPad OS and frequent backups to protect my data. This reliance was apparently misplaced. Since I used the iPad for a number of business related applications, I guess I am out of luck. This is apparently one of the risks of not having a file sysem and having data integral to applications.


    Moral of the story for me: I guess I can't rely on the iPad and its backups to protect data that is stored with the application.


    Color me seriously disappointed and disillusioned with Apple software reliability


    PS The multiple icons issue "went away" after the above log out/log in cycle in iCloud.

  • JohnZonie Level 1 Level 1 (30 points)

    OK, the silver lining appears. I finally heard from iTunes support (with an apology for the delay).  They reset my account so that the above "Device already associated..." no longer appeared and all books were able to be ownloadable.


    After talking with Edward at AppleCare (incredibly fast on the uptake of the issue and very knowledgeable), it turns out data associated with an app is actually backed up separately. It is apparently restored "somewhere" on the iPad. So, even though I had only the default apps on the iPad, I was able to go the the store, Purchased apps page and download them. When the app was downloaded, the data was there! This happened with all the apps. All my data was still there.


    While it was a bit tedious to load all the apps, it did provide an opportunity for some housekeeping.


    Thought I'd close the loop on this saga on a happy note

  • Kilgore-Trout Level 7 Level 7 (30,065 points)

    Glad to hear you got it worked out.