7 Replies Latest reply: Feb 15, 2013 3:34 AM by MunchOff
MunchOff Level 1 Level 1 (0 points)

Tried to follow the steps but they don't match what I ahve. Any ideas?

 

Kayles


MacBook, OS X Mountain Lion (10.8.2), 1st Gen Unibody.
  • MrHoffman Level 6 Level 6 (13,150 points)

    The local user's ~/Library folder has been hidden in recent releases.  It's still around, but it's been added to the list of stuff that doesn't show up (by default) in Finder.  The system-wide /Library folder remains hidden.

     

    As for your question, I'm not certain what you're working with here, and some details could help me understand that.  (Part of my confusion: this is an OS X Server operating system forum, and it's not common to encounter the Snow Leopard Server OS X Server 10.6 software loaded on a MacBook.  There is a Server folder involved with that package; that's where the management tools are stored on an OS X Server configuration, and also when the server tools package is installed on OS X client.  There's also a mail server involved.)

     

    I'm going to guess that this isn't Mountain Lion Server OS X Server 10.8, though...

     

    What steps are you looking at, and that don't match what you're (not) seeing?

     

    What application(s) are involved?

     

    What version of the application(s)?

     

    Your footer shows Outlook.com; if this is a mail-related question, is that your mail server here?

  • MunchOff Level 1 Level 1 (0 points)

    Right, I followed the above link from Google and tried following these instructions:

    For OS X Server (Mountain Lion)

    1. In /Library/Server/Mail/Config/postfix/main.cf, locate the smtpd_helo_restrictions setting.
    2. Remove "reject_non_fqdn_helo_hostname" from the list of settings.
    3. Restart the Mail service.

     

    I'd  been looking for a while so was a little desperate at that point and didn't read 'server' before Mout Lion. Either way;

     

    I'm going to guess that this isn't Mountain Lion Server OS X Server 10.8, though...

    (Correct - I'm normally not this thick, sorry lol)

     

    What steps are you looking at, and that don't match what you're (not) seeing?

    (Step 1 - /Libarary/Server < - - Issue, though I now understand why)

     

    What application(s) are involved?

    (Apple's in-house mail app, Mail 6.2)

     

    What version of the application(s)?

    (6.2)

     

    Your footer shows Outlook.com; if this is a mail-related question, is that your mail server here?

    (Yes. Hotmail and Gmail set up super easy, but it doesn't seem to like Outlook)

     

     

    Any thoughs? Even a push to the right thread would be a help, the Apple forum does confuse me somewhat.

     

    Thanks for the assist.

  • MrHoffman Level 6 Level 6 (13,150 points)

    OS X Server is different from OS X client.  If you want to run a mail server (which also generally requires static IP and public DNS), then acquiring that package is the easiest way to deal with this.   And you'll probably be working with Postfix settings and related.

     

    However, it appears you're possibly tangling SMTP server-side settings, OS X Server settings, and Mail.app mail client settings together.  The reject_non_fqdn_helo_hostname setting only works on a Postfix mail server, for instance.  This and other Postfix settings are server settings.  These settings are unrelated to Hotmail, Gmail and Outlook.com; the administrators of those mail servers will have configured the server-side settings as they need, and it's up to you to configure the mail client settings.

     

    Here are the mail client settings for Outlook.com.  The set-up and ports look fairly typical of most any recent mail server set-up; The send path SMTP TCP port 587 with SSL/TLS enabled, and the IMAP receive path is TCP 993 with SSL/TLS.  Not sure why you're having issues, but the Mail.app Connection Doctor tool (Mail.app > Window > Connection Doctor) might help locate the trigger.

  • MunchOff Level 1 Level 1 (0 points)

    I deleted my account off the program and re-adding. i get this message to start:

     

    The outlook.com Exchange IMAP server “pop3.live.com” is not responding. Try checking the network connection, and that the server name is correct. Otherwise, the server might be temporarily unavailable. If you continue, you might not be able to receive messages.

     

    This is just after putting in my username and password, which I've checked are correct. Its also what I get with the doctor app.

     

    I press continue anyway.

     

    Changed the account type to IMAP, I get the same message again. Press continue anyway. In preferences the SSL number in 995 so I changed it to 993, and all of Mail stopped sending/recieving. Changed it back and it's now froze so had to force quit. SSL on the send prefs is enabled automatically and 'use defult ports' is selected and one the them is 587.

     

    I'm not sure what to try next.

  • MunchOff Level 1 Level 1 (0 points)

    However, I can now send emails. 1/2 way there.

  • MrHoffman Level 6 Level 6 (13,150 points)

    Mail uses two paths.

     

    One for retrieving messages from the server, and another for sending messages. 

     

    The host server Mail.app (or whatever client) you're receiving your mail from doesn't have to be the same host as the server you're sending, too.

     

    SMTP or a variant is used for sending mail from your client to your mail server, and from there to the recipient.  This means you specify the hosts and ports as documented by the provider, and whether SSL/TLS is enabled or disabled.

     

    The two protocols commonly used for receiving mail from a server are POP, and IMAP.   (Given the choice, I'd almost always use IMAP.)   This means you specify whether you're using POP or IMAP, the host name you're receiving your mail from, and whether SSL/TLS is in use.

     

    In the case of Outlook.com, you need to log in (via the web mail interface) to see which server(s) you need to specify for sending (SMTP) and for receiving (POP or IMAP) mail.  You'll then use these servers in your set-up.

     

    Check your settings for the receive path.  POP or (preferably) IMAP, with the right host, with the right port, with SSL/TLS enabled or disabled.

  • MunchOff Level 1 Level 1 (0 points)

    Resolved.

    Took a lot of adding and deleting the mailbox with different ports, stuff enabled etc, but we got there.

    AND I learned a bit about smtp and pop and how stuff works. An educational experiemce.

    Thanks again.