5 Replies Latest reply: Nov 11, 2014 4:37 PM by Bob Coates
milky210776 Level 1 Level 1

Hi, my card reader started to become inconsistant over the last week and it has now stopped reading cards all together. It will show up in Disk utility so i can format it etc but it just wont show in the Finder section. When i remove the card without prompting, i get the 'Failed to eject properly' message. Any advice would be appreciated. I only purchased in Nov 2011 brand new so not sure what operating system it is but you may know from date of purchase.

Thanks

Rob


iMac
Solved by BDAqua on Feb 7, 2013 3:38 PM Solved
Hi Rob, in Disk Utility can you Verify Disk? Can you highlight it & click the Mount icon? In Finder>Preferences>General & Sidebar, are they still set to show up?
  • BDAqua Level 10 Level 10

    Hi Rob, in Disk Utility can you Verify Disk? Can you highlight it & click the Mount icon?

     

    In Finder>Preferences>General & Sidebar, are they still set to show up?

  • milky210776 Level 1 Level 1

    Hi there, thanks for your assistance. I have tried the verify disk comment you stated. When i click on Mount icon, it takes me through and shows the SD card there which i can actually drag and drop a file into it and it will successfully load up but still no show in finder.

    Can you please clarify further to the Finder instructions as when i click on Finder, i cant see preferences to be able to advance to check general and sidebar?

     

    Thanks so much.

    Rob

  • milky210776 Level 1 Level 1

    Hi, great stuff. Ive managed to resolve the issue off the back of your verify disk statement. I dragged the SD from this over to finder and it now shows. Wahhay. Thanks so much.

    Best wishes

    Happy bunny.

    Rob

  • BDAqua Level 10 Level 10

    Good work, great news, thanks!

  • Bob Coates Level 1 Level 1

    I had this problem too on my MBP mid-2012 running Mavericks.  SD cards (in MBP slot or USB reader) would not show up in Finder.  I was able to see them mounted in Disk Utility.  What tipped me off that they were in fact mounting (and led me to check Disk Util) is that the OS complained of improperly ejecting the sd card when I removed it.

     

    To clarify what BDAqua said, but I didn't understand until I saw another thread, here's what fixed my problem:  Click on 'Finder' 'Preferences', select Sidebar tab and tick the box 'external disks' in the Devices section.

     

    Now my sd cards show up.  Thanks!!