7 Replies Latest reply: Feb 18, 2013 2:21 PM by Fabian Frank
goldenmean Level 1 (0 points)

My Airport Extreme Base Station won't update firmware to 7.6.2. When clicking update in the Airport Utility application, it seems the firmware is downloaded and then only returns this error in a modal window.


An error occurred while updating the firmware.




The modal window has only an "Ok" button for dismissal. No other information is presented. Is this a known issue? Is there a solution?

Mac Pro, Mac OS X (10.7.5)
  • XSerban Level 1 (10 points)

    Had the same problem. As soon as I restarted my airport extreme, it worked right back and presented with a 7.6.3 version. Even though I have all Apple hardware now, I have to say that the more I get to know them, the more frustrated I get.


    My shared drives connected to the airport extreme don't work as advertised. It's a terrible product Screen Shot 2013-02-07 at 11.27.41 PM.png

  • Shawn Grinter 2 Level 3 (950 points)

    Odd, I have a shared disk on my AE and it's been perfect - what problems have you had?


    Note if you try to use this for a Time Macine device you *will* get problems




  • XSerban Level 1 (10 points)

    Thanks Shawn. I had an Airport Express which worked just fine. Bought the Airport Extreme just to be able to share my large drives over the network. And this is where problem start:


    1. Tried with a single drive first that I use to download stuff. My downloads pause every few minutes and it's very hard to have a sustained download rate. Initially I blamed my Internet connection but once I noticed the next problems, it had to be the Airport's fault.


    2. I have connected 2 more drives using a good quality, powered, USB hub. Problem #1 persists and the same thing happens with the other drives while I'm trying to access them. Sometimes they wake, sometimes they don't. Even Finder crashes sometimes because of this. And this is the main reason Time machine might not work either (haven't tried yet but I'll take your word for it).

    I'm also using XBMC and the movies are loaded on the USB drives. It's a real pain to try to launch a movie. Most times it won't start.


    So.. Apple aren't at all who they claim to be. They should prioritize to fix their **** (WebDav no longer works properly since Mountain Lion either) before Microsoft wakes up or Ubuntu catches more ground.


    We desperately need a great Computer/Software company cause we don't have one yet....

  • Bereanone Level 1 (0 points)

    I have had no end of trouble for some time now.  Yesterday was on the phone to Apple for half an hour, no luck. Still very unstable.  Today, up pops this new firmware update.  It seems that if I recall, my problems started with the last firmware update.  Well I have installed 7.6.3 and so far no problems. I use an external USB drive with two partitions, one for Time Capsule, and the other for general purpose, video streaming, etc.  So far no problems.  Time capsule has functioned, I have moved files around, created new folders, and am currently streaming a video off of it.  Has not broken yet, knock on wood.

  • XSerban Level 1 (10 points)

    good for you Bereanone. My problems are persisting though...

  • Zooted11 Level 1 (0 points)

    I had the same problem but I got mine to work by restarting my computer and unplugging my Extreme for 30 sec. When my iMac rebooted n i plugged the Extreme back in and webt to Utility n the firmeware downloaded immediatly.

  • Fabian Frank Level 1 (0 points)

    7.6.3 was an endless string of issues for me, whereas 7.6.1 worked fine for ages. I'd recommend everyone to stop fiddling with 7.6.3 and just use 7.6.1.