2 Replies Latest reply: Feb 8, 2013 5:25 AM by Tom Gewecke
debjg Level 1 (0 points)

All of a sudden today, my documents folder is opening .rtf files with a bunch of added code ...

no longer documents I can simply send to the printer as before (which is nauseating).

Any way to fix this?


For example, I typed out 'testing save of document', saved the file to my documents folder,

and this is how it opened on retrieval:



{\fonttbl\f0\fswiss\fcharset0 Helvetica;}



\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx792 0\tx8640\pardirnatural



\f0\fs24 \cf0 testing save of document}


I'm also no longer getting the option to 'Save' or save as something else when changes are made ...

the document simply closes upon 'Save' (only saving option).


Are all my files corrupted and do you think it's the particular file type, Documents folder ... or what?


Thankful for any help ... it hasn't been a good computer day at all

iMac 20" 2.66, Mac OS X (10.5.6)
  • BDAqua Level 10 (121,630 points)

    Could be many things, we should start with this...


    "Try Disk Utility


    1. Insert the Mac OS X Install disc, then restart the computer while holding the C key.

    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu at top of the screen. (In Mac OS X 10.4 or later, you must select your language first.)

    *Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.*

    3. Click the First Aid tab.

    4. Select your Mac OS X volume.

    5. Click Repair Disk, (not Repair Permissions). Disk Utility checks and repairs the disk."




    Then try a Safe Boot, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when it completes.


    (Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.)


    If perchance you can't find your install Disc, at least try it from the Safe Boot part onward.

  • Tom Gewecke Level 9 (76,405 points)

    Go to TextEdit preferences > open and save > opening and make sure that the box for "ignore rich text commands in RTF files" is NOT checked.