2 Replies Latest reply: Jun 6, 2013 1:44 PM by Murkhul
kmbro Level 1 Level 1 (0 points)

I have 2 Cisco ASA devices that I need to access.  One offers ASDM 6.3 and the other ASDM 6.4.  I have no control over the version.


Previously I've happily visited the ASA's IP address using Safari, clicked Run ASDM, double-clicked the .jnlp file in my Downloads folder (I've set Safari to not auto-launch downloads), and got on with it.  I've also been able to use the desktop shhortcut that the applet creates.


With the 2012-006 Java update from Apple things no longer work.  Firstly I went ahead and downloaded the Java 7 update from Oracle.  Then I discovered that ASDM 6 isn't compatible with Java 7 so I followed the downgrade instructions at http://support.apple.com/kb/HT5559 and verified the downgrade at http://www.java.com/en/download/installed.jsp.  Then I tried Run ASDM again.  Here's what happens when I launch the asdm.jnlp file...


  • Verify Ceritificate windows pops up (because the router doesn't have an official certificate) so I click Trust.
  • Splash screen pops up very briefly saying Downloading
  • Splash screen switches to saying Verifying Application
  • Splash screen disappears and nothing more happens


Having done the same things on a Windows machine, this is the point where the desktop shortcurt gets created.


I only get the splash screen the first time I run the jnlp file.  I assume this is because the applet get cached.  If I run "javaws -uninstall" and then "open asdm.jnlp" then I get the splash screen again.


One other thing that might be relevant, or might not.  If I run "javaws" from a terminal command line then I get


Java Web Start splash screen process exiting ...

Can not find message file: No such file or directory


But if I do "export LANG=C" first then I get the startup options listed.  "locale" normally reports everything as "en_GB.UTF-8", so something is screwed with the internatinoalisation, I'd guess.


So can anyone tell me what I need to do to get ASDM up and running, or at least how to investigate why the app is crashing out?


At the moment I can get access from a VMware Fusion Windows 7 virtual machine, but I'd prefer to do it native.

MacBook Pro, OS X Mountain Lion (10.8.2)
  • kmbro Level 1 Level 1 (0 points)

    Okay, this is weird.  I clicked on "Run Startup Wizard" instead of "Run ASDM" and it ran!  I was able to quit Wizard mode and use the standard ASDM functionality.  What gives?  It suggests that the Java installation itself is okay but I've got some duff ASDM-specific data in a cache somewhere.  But where?!  I tried removing the ~/.asdm and ~/Library/Caches/Java directories but that didn't solve it.

  • Murkhul Level 1 Level 1 (0 points)

    Were you able to find a solution for this?  I am having the same issue, and I have not been able to find a resolution.  I did try your work around, and surprisingly it worked for me.  Kind of annoying, but workable.  I might have to force the update on the ASA to the latest, when I can, it just won't be soon.  Anyways, thought I would see if you had any success, if not, your workaround helped out!