Previous 1 2 Next 24 Replies Latest reply: Feb 8, 2013 10:21 AM by dwb
Drewinfrance Level 1 Level 1

Hi,

 

I have tried all of the solutions found on various forums but I still can't delete a file in the trash can.

 

Does anyone know why I can't delete it?

 

When I tried to empty the trash can it said that the file can't be deleted because it can't be read or written. However when I looked at the file info it said it could be read and written. The file is an .exe unix from a windows 7 partition.

 

Any solutions?

 

Thanks


MacBook Pro (15-inch Early 2011), Mac OS X (10.7.2)
Solved by Linc Davis on Feb 8, 2013 9:16 AM Solved

Boot into Windows and run the chkdisk program.

Reply by Roger Wilmut1 on Feb 8, 2013 9:10 AM Helpful

Drewinfrance wrote:

 

The file is a .exe unix file from the windows partition that I deleted by mistake whilst using OSX. I've tried to put the file back in it's original folder on the bootcamp partition which worked but a copy of the file stayed in the trash (and yes I made sure that the file was being moved and not copied).

When we've met this one before it's had to be solved by deleting it in Windows rather than the Mac - though if you've been deleting volumes I don't know what the implications of that would be.

Reply by Csound1 on Feb 8, 2013 9:19 AM Helpful

That's not what I meant, and this may just be useless anyway but locate the copy in Windows and delete it, empty the Windows trash (copy the file off the machine if you need it) does this have any effect?

 

Try Linc's suggestion, I should have thought of it

All replies

Previous 1 2 Next