5 Replies Latest reply: May 30, 2014 2:13 PM by Vietto
George Johnson Level 2 (265 points)

This is a new Air (2012) running Mountain Lion 10.8.2.  The location is a Sheraton hotel that uses iBahn for Internet service. I can connect to the wifi network "iBahn," and the Network preference panel shows that my Mac has been successfully assigned an ip number. I click the advanced tab and confirm that iBahn's DNS servers are now listed there. But when I open the browser and try to connect, I cannot get the hotel log-in page. I get a blank window instead. Reloading the window does not help. I have tried the usual remedies: turning wifi off and then back on again, requesting a new DHCP lease, closing and reopening the browser, trying different browsers (Firefox, Chrome), restarting the computer -- none of this works. I have tried shutting down the Mac, restarting, and signing in to a different account on the computer. The symptoms are the same -- a blank page instead of a log-in screen. I have had no trouble connecting with several other wifi networks elsewhere -- including ones that require a browser log-in page. Later the same morning, the wifi at the airport worked just fine.



Here is where it gets even weirder. I happened to have a second Mac Air with me -- a 2010 model. It logged on to the hotel network with no problems: I opened the browser and the log-in page immediately appeared.



And weirder: There was also an ethernet cable in the room. When I plugged that into the 2012 Air (with a USB-ethernet adaptor) I could connect with no problem. Finally, I found that I can plug an Airport Express into the ethernet cable and the 2012 Air will connect wirelessly through that.



What could be wrong here? I assume that iBahn works by obtaining and registering a machine's MAC address. Using wifi, Ibahn was able to get the MAC address from the older 2010 Air and from the Airport Express, but not from the 2012 Air. But the 2012 Air could provide its MAC address through a wired connection. Any advice would be most appreciated. Though I was able to come up with a workaround, I want to ensure that this doesn’t happen elsewhere.

MacBook Air, OS X Mountain Lion (10.8.2)