4 Replies Latest reply: Feb 8, 2013 3:31 PM by Pancenter
BenSandford Level 1 Level 1 (0 points)

Hi all,

 

I am very new to Logic Pro 9 so I will put this down to user error. I wonder if anybody can help me? I know that this subject seems to be a common thread on here but even after reading through all of them I still can't seem to find an answer or fix.

 

I am having trouble getting a Tascam US-122mkII to record any of my instruments in Logic Pro 9. The main issue is that I don't seem to get any sound, input or output signal when I play or try to record. The Tascam is receiving a signal from my instruments but it's not sending it into Logic.

 

I know I can record with it as the other day I some how accidentally managed to record my bass guitar and synth, however since trying to start an empty project I get nothing again.

 

I will run through everything I do and maybe someone can't point something out.

 

Open empty Project and create a new audio track with the following settings.

Format - Mono

Input - Input 1

Output - Output 1-2

Record Enable - Checked

Open Library - Checked.

 

Preferences

Output Device - Built In output

Input Device - US-122MKII

I/O Buffer Size - 256

Universal Track Mode - Checked

24 Bit Recording - Checked

Software Monitoring - Checked

 

If I go onto the Mixer tab and click options and then I/O Labels I have Input 1, Input 2 and Input 1 - 2 ticked in the 'Provided by Driver' column

 

In the inspector under the channel strip settings it is basically empty apart from the software instrument plug in reads as US-122Mkll, Stereo Out, Off.

 

I hope I am making some sort of sense here, I have tried to paint a bit of a picture of what I am doing and the settings that I have used.

 

What am I doing wrong or missing? Any help would be gratefully accepted.

 

Ben


Logic Pro, OS X Mountain Lion (10.8.2)
  • Pancenter Level 6 Level 6 (8,975 points)

    Hi Ben,

     

    Do you have a pair of headphones you can plug into the Tascam?

     

    my opinion here:

     

    When you purchase an audio interface I assume it's for better sound and a variety of Inputs. So why would you defeat the improved sound by playing back through the noisy $2 Built-In audio chip of the Mac?

     

    Try setting the Output Device to the Tascam.

     

    The Inputs you see 1 & 2 should match the Tascam's so plugin your bass to Input 1, create a new project with 4 audio tracks. Set all of the tracks as mono tracks. Set up the tracks as having alternate inputs. Tracks 1 and 3 Input 1, Tracks 2 and 4 Input 2. Make sure the Tascam is selected as both In/Out device.You can use this simple project to get the hang of recording audio. Now, to monitor your input you have two choices, software monitoring and hardware monitoring, you already have software monitoring enabled so use that. Enable Record on Track-1 you should hear your bass through the headphones, with a slight delay... this is latency, you can reduce latency by reducing the "I/O Buffer Size" the tradeoff is higher CPU use and possible glitches under heavy load.

     

    If you're good so far, set the I/O Buffer to 128

     

    You understand that MIDI is not audio, MIDI is a separate animal and I presume you're just dealing with audio tracks?

  • Pancenter Level 6 Level 6 (8,975 points)

    Of course, make sure you're using the latest Tascam driver downloaded from the Tascam site.

  • BenSandford Level 1 Level 1 (0 points)

    Hi Pancenter,

     

    That seems to have done the trick, I changed the output to the Tascam and updated the driver which I had already tried previously but forgot to update the firmware. So far so good, thank you very much! The reason I was keeping the output to the built in audio chip was because I have my speakers connected to the iMac jack input, until I can get some good studio monitors.

     

    Yes I understand that MIDI is a separate animal, and for the minute I am just playing around with audio tracks.

     

    Thank you again for your help, I really appreciate it.

     

    Ben

  • Pancenter Level 6 Level 6 (8,975 points)

    That seems to have done the trick, I changed the output to the Tascam and updated the driver which I had already tried previously but forgot to update the firmware. So far so good, thank you very much! The reason I was keeping the output to the built in audio chip was because I have my speakers connected to the iMac jack input, until I can get some good studio monitors.

     

    Ben, you're welcome...

     

    The reason I mentioned using the same unit for both Input/Output is twofold. Better sound yes but there's also technical reasons involving sync (digital clock) and resampling that can further deteriorate sound.

     

    Before Logic 9 you could only select one audio device, Logic 9 made adjustments and added the Garageband option of setting both Input and Output device...  a nod to the average consumer, just be aware nothing is free and if sound is important stick with a single device if at all possible.