10 Replies Latest reply: Mar 30, 2015 6:05 PM by BennyB-DoubleDigit
Greuvenmusic Level 1 Level 1 (0 points)

This is a very weird glitch that happens under a very specific set of circumstances, that I believe is caused by a bug in Logic. If anyone could shed light on it, it would be much appreciated.

 

I normally record midi using the Capture Recording tool, which I find far more convenient (and less pressure) than actually hitting Record. I routinely record multiple passes on a single track, with Cycle both on and off. I'll often record different midi CC's on different passes, then merge the regions afterwards. Usually, this works with no issue.

 

Today, for some odd reason, recording a second pass created a take folder. After doing some investigative work, it seems that this only happens, at least initially, when a midi controller is mapped to a specific control in the instrument. (I'll get back to the specifics in a bit.) Bizarrely, though, once that's happened, it seems to open the floodgates, where it starts randomly occurring on other tracks (both Instrument tracks and Midi tracks triggering external instruements), including on the first pass, which will randomly be split into multiple takes. (Even more infuriating, flattening those takes only preserves a section, making it almost impossible to retain the performance without extra work.)

 

As for the details, this started happening using Heavyocity libraries (it happens with Evolve, Evolve Mutations 1&2, and Damage), loaded in Kontakt 5.1. When I use a midi CC that is mapped to one of the parameters on the instrument (e.g. CC74) and capture the recording, a take folder is automatically generated. If I use a controller that does nothing (e.g. mod wheel), a normal region is created. However, if I remap the parameter to the mod wheel, that then generates a take folder as well.

 

Once this happens on one track, it starts happening on other tracks, including Stylus RMX, EXS24, and even midi tracks sending to a slave machine over ipMidi, including when recording just notes, and no controller data. Quitting and relaunching Logic usually fixes it for a little while, but then it will start happening again.

 

I've verified that it's not caused by file corruption, which I initially suspected, by recreating it in a fresh empty template. I've also deleted and reset the Logic preferences to no avail.

 

Under Project Recording Settings, MIDI Overlapping Regions is set to "Merge only in Cycle Record". (On a side note, how is there no option of "Record Normally" or "Do Nothing" here?!) In any event, I've tried switching this, but it doesn't resolve the issue.

 

There is no complex routing going on in the Environment on any of these tracks.

 

At this point, I've run out of ideas on how to fix this issue.

 

Reuven

 

Logic Pro 9.1.8

OS X Mountain Lion 10.8.2

2012 Mac Pro 12 core 3.06 GHz

64 GB RAM

RME HDSPe Raydat


Logic Pro, OS X Mountain Lion (10.8.2)
  • hazza26 Level 1 Level 1 (0 points)

    I've got exactly the same problems Greuvenmusic. Started happening out of the blue, now it won't go away.

     

    Did you make any headway with it?

     

    Thanks

  • LogicNinja Level 1 Level 1 (0 points)

    Yes, same problem here.  It started with an instance of Kontakt 5 in Logic 9.1.8 as well and a midi controller being mapped to one of the parameters in the instrument.  I've been using Capture Recording since 2005 so almost eight years and today is the first time I'm experiencing this problem.  As a matter of fact, I wasn't aware that you could have multiple take folders on a midi track until it just appeared today.  I now see that you can set that function in recording settings, however it never was apparent to me because it's useless to my workflow.

     

    I honestly can't imagine a more fatal flaw then Capture Recording not working, it's imparative to my workflow and as I'm working on TV/Film deadlines in LA there is absolutely no time to waste dealing with folders.  I barely have enough time on projects with my current workflow so I'm not sure how to deal with this new issue.

     

    I hope we can find a solution, I've seen only a couple posts regarding this issue so it seems to be very new.

     

    Thanks!

  • CCTM Level 6 Level 6 (9,930 points)

    Hi

     

    I've just had a quick look at this, and can confirm:

     

    With K5 on OSX 10.8.3, I get spurious Take folders when MIDI CC's are mapped to controls within K5

    I get similar with Logic 9.1.8 and 9.1.7 (same OS) in 64 bit or 32 bit mode.

     

    With OSX10.7.5 I get the same result with K5 and K4.

     

     

    Removing the mappings in Kontakt removes the Take folder creation problem

     

    Removing the Instance of Kontakt removes the problem

     

    I cannot reproduce with other MIDI Mapped plugs (Stylus RMX etc).

     

     

    Greuvenmusic wrote:

     

    (Even more infuriating, flattening those takes only preserves a section, making it almost impossible to retain the performance without extra work.)

     

    As a work around, use the Unpack or Unpack to new tracks functions, then use the glue tool to merge back together.

     

     

    HTH

     

     

    CCT

  • itchyrich Level 1 Level 1 (5 points)

    Got the same problem in Logic X 10.0.6. just started today, never had this bug before. has anyone figured out why this is happening?

  • itchyrich Level 1 Level 1 (5 points)

    did you find a solution to this problem?

  • David Chamberlin Level 1 Level 1 (0 points)

    Same issue over here since 2009. It's not on all Kontakt instruments but possibly with more script heavy ones. The current issue is when using Embertone Violin and Cello. Logic X cannot capture take. I haven't noticed with other VIs, plus with Kontakt 5, it's not consistent. Usually it works.

  • BennyB-DoubleDigit Level 1 Level 1 (0 points)

    I'm having the same problem since I upgraded from Logic Pro 8 to X. Like you Greuvenmusic, I pretty much always use the capture as recording command to construct patterns and phrases. On that note, I found one setting that was helpful under the Record menu, there's a setting "Allow Quick Punch-In" which seems to improve Logic's ability to capture. Why this is a feature that you have to enable seems a bit ridiculous, but only on par with some of the other "improvements". Still though, I'm unable to join midi regions about 99% of the time as someone else mentioned. This practically makes the program unusable (at least in my opinion), which is a real slap in the face after having just shelled out $200.

     

    Having used Logic for years now I find myself faced with the difficult question of whether or not to just switch to a new DAW, which makes the $200 even more frustrating. At this point I've lost all confidence in Apple's commitment to its professional users. Clearly the iOS devices are where the money is and for a longtime Mac user and enthusiast, the scope of the decline in quality for its non-iOS products is beyond disappointing. I heard a lot of video professionals have had to abandon Final Cut Pro after the latest release. But that's another topic.

     

    Anyway, hopefully someone will come up with a fix for the problem at hand in this thread. I will return to comment if I have any luck myself. Good luck =]

    ~Benny

  • The Art Of Sound Level 6 Level 6 (9,490 points)
    I heard a lot of video professionals have had to abandon Final Cut Pro after the latest release. But that's another topic.

     

    ...and frankly inaccurate....

     

    Initially many people 'threatened' to do so but then after a few updates which provided for some of the 'missing features' these users were used to having... such 'threats' diminished... People just don't like change and so, typically that is exactly what happens everything something major is changed... and people are impatient waiting for updates.. for features that go missing, only to be replaced or updated/reintroduced later on...

     

    Its a fact of modern life... and largely such threats and the people who make them...  are just ignored... especially on a user supported forum such as the ASC

     

    Anyhow Benny,

     

    As for your specific issues.. I use capture all the time with K5 (v5.4.3).. and do not have any such issues now with 10.10.2 and LPX 10.1.1... and I never had any issues joining Midi regions... throughout testing... nor during every day use.

     

    Having said this my main rig is still 10.6.8 and LP9.1.5 and will remain so as it's the best in terms of overall performance and stability but my testbed rigs on which i have LPX and Yosemite are both working well.. Much better in terms of performance and stability than prior to the LPX 10.1.1 and OS X 10.10.2 updates...

     

    Same issue over here since 2009. It's not on all Kontakt instruments but possibly with more script heavy ones. The current issue is when using Embertone Violin and Cello. Logic X cannot capture take. I haven't noticed with other VIs, plus with Kontakt 5, it's not consistent. Usually it works.

     

    Mike, I actually have Blakus Cello and I just tried using capture with it, LPX 10.1.1, K5 v5.4.3 and Yosemite10.10.2 on two different testbed Macs (2015 Mac Pro and 2011iMac) and after repeated captures, I could not recreate your issue at all.... All caps worked exactly as i expected even with many articulations being changed a crazy number of times...just for test purposes..and I also did not have or need to have "Allow Quick Punch In" enabled...

     

    So, I can only assume either.. its a very random issue and it only happens now and again under very specific circumstances that i couldn't recreate and/or i was really lucky, or... its something specific to certain systems and/or configurations..

     

    If you or Benny could post up any specific steps I need to take to recreate this on a regular basis.. I'll try them out on both rigs and see what occurs...

     

    Cheers..

     

    Nigel

  • BennyB-DoubleDigit Level 1 Level 1 (0 points)

    Thanks for your reply Nigel. I have some thoughts on your comments about Final Cut, which I would be interested in coming back to at some point  if time permits, or it can be done in a way which provides something useful to the conversation, not just bickering, which is the last thing I would come here to do.

     

    At any rate, I’ve tried some different tests to see under what circumstances I can duplicate the problem (or not, depending on how you look at it). First, I tried just combining some regions with notes I entered using the pencil tool. No problems here. Second I tried switching from a Kontakt instrument to something out of the factory content, which by the way at first glance looks to have been impressively revamped. The problems persisted here though as well.

     

    In terms of what these regions look like, mainly it would be something like one region spanning a four bar cycle with a drum pattern either captured or recorded in cycle mode. Secondary regions would be say; an extra kick entered somewhere, say; the fourth bar. I can click on the one bar region then shift click on the underlying region and choose to join them using the appropriate command. In the docked Piano Roll it will momentarily look as though the operation worked, but as soon as I select the region(s) in the tracks window it becomes clear that the operation wasn’t successful, as one of them moves and the other stays put.

     

    I also tried creating adjacent midi regions next to each other, entered in the same way; live or captured with only one region each; not overlapping and joining these was also unsuccessful. The commands are being logged into the undo history as if they’ve been completed successfully. I’ll also add that I’ve tried joining the regions using the keyboard shortcut and manually entering the command via the menus in the Tracks window, the Piano Roll editor, and the Events List, which predictably all do the same thing but; hey, it's worth being thorough.

     

    Looking more closely at the midi regions it seems that there’s been a change in the way that Logic X treats these in cycle record, which looks similar to the way audio input recordings are captured in cycle mode with “takes” (I think) selectable in place as a dropdown menu. On the midi regions I can see in some cases that there’s a triangle which seems to show the various ‘takes’ when you click on it. Maybe if someone explains the way these ‘takes’ function in Logic X I could get at least a step closer to solving this issue.

     

    Thanks again Nigel, I appreciate your offer to look into the matter. Hopefully the info I provided above gives you or any of the other users some ideas about ways to potentially resolve this issue.

     

    ~Benny

  • BennyB-DoubleDigit Level 1 Level 1 (0 points)

    So, I have some progress to report on the matter.

     

    BennyB-DoubleDigit wrote:

    Looking more closely at the midi regions it seems that there’s been a change in the way that Logic X treats these in cycle record, which looks similar to the way audio input recordings are captured in cycle mode with “takes” (I think) selectable in place as a dropdown menu.

     

    Indeed, this appears to be a new feature in Logic X (maybe before that?) which treats Midi captured in cycle record in the same fashion as audio recordings ‘packing’ the takes into a take ‘folder’. This is accessible from the Tracks window under “Functions” the last menu item “Folders” contains options, such as “Pack Folder”, “Unpack Folder to New Tracks”, etc. Or use the respective keyboard shortcuts.

     

    I found this by searching for “folder” in the Logic Pro X Help menu. Although they only explain this in the context of audio recordings:

     

    Record your voice or a musical instrument > Manage take folder contents

     

    the same Logic applies to Midi regions, even if it seems they failed to mention it.

     

    So in essence, it seems the reason that I was unable to join some of these Midi regions had to do with the fact that one or more of the regions were ‘take folders’ and not merged regions.

     

    In practice, it’s actually potentially a kind of cool feature, as it lets you capture several ‘takes’ and compare them in place. For practical purposes however, this definitely seems like a feature that ought to be accessible through an advanced menu, so power users can take advantage of it if they choose to do so. As it stands, having this set to be the default feels a bit like putting a stick shift in a minivan. I’m not crazy about it as a default that I can’t switch, but as long as I can figure out how to render ‘takes’ into normal regions that I can join and edit in one place, I ought to be able to adapt my workflow around it.

     

    There’s still some pretty dodgy handling of “ghost” Midi, that you can hear bot not see until you de-select/re-select some element of the UI, or what I might refer to as “Total Recall” Midi (“do you think this is the real Houser? it is… [for the majority of those of you who don’t ‘get it’, don’t sweat it ;-) ], but hopefully they’ll deal with this in a future update. For now I can live with it.

     

    Anyway, hope this helps some of you folks out there. Good luck =]

     

    ~Benny

     

    PS - anybody want to mention how to use blockquotes properly here? I had to do a fake indenting bit, since the content showed up wrapped in <blockquote> tags (not very good for readability)

     

    Thanks~B