7 Replies Latest reply: Mar 21, 2015 12:19 PM by Chris CA
Paresh Devani Level 1 Level 1 (10 points)

I'm still using iTunes 10.7 as the reviews / issues with version 11 do not seem very flattering!

When I import a multi-artist compilation CD into iTunes, it 'splits' the album into individual artists and songs categories in the iTunes window, and subsequently into the iPod when transferred there.

Is there a workaround / solution for this? I would prefer to have compilations as single album collections of songs, just like the original CD.


MacBook Pro with Retina display, OS X Mountain Lion (10.8.2), 15", 2.6GHz, 8GB
  • Jimzgoldfinch Level 5 Level 5 (6,565 points)

    Hi,

    Select all tracks and get info. Enter "various artists" in album artist field. Make sure that all tracks are marked as part of a compilation.

     

    Jim

  • Granavel Level 1 Level 1 (35 points)

    All compilations are in a Compilation section, there's no necessity to enter a name in album artist field, it can be empty.

     

    If you enter a name in album artist field then you don't need check tracks as parts of a compilation and then the album won't be in the compilation section but will be at artist name you set for album artist field.

     

    Also take care that you can have troubles wirth sort fields.

     

    The more simple is to remember do it before importing a CD and remember check the album is a compilation : Cancel the import, select the CD, right click for context menu, Get information then check it's a compilation, then import the CD.

  • Jimzgoldfinch Level 5 Level 5 (6,565 points)

    Hi,

    Have a look at this

     

    http://samsoft.org.uk/iTunes/grouping.asp

     

    Jim

  • deus4ko Level 1 Level 1 (0 points)

    You need to enter the album artist i.e. Various Artists to group split compilations back together in Get Info section. The problem I faced was that it would not save the album artist field after i entered it. The Solution is to go to the directory where you store the files, go into Properties and UNCHECK the file READ ONLY attributes. This solution is a fix for after you realize that your 100 song compilation albums has split into 100 albums.

    Now you can add all the tags and album art you want. What was annoying is that Itunes did not tell you it did not save the changes because the file was read only. Apple needs to add that error message otherwise people will be clueless.

  • Chris CA Level 9 Level 9 (78,005 points)

    deus4ko wrote:

    You need to enter the album artist i.e. Various Artists to group split compilations back together in Get Info section. The problem I faced was that it would not save the album artist field after i entered it. The Solution is to go to the directory where you store the files, go into Properties and UNCHECK the file READ ONLY attributes

    except Mac OS does not have “Properties”. This is the iTunes for Mac forum.

    Mac OS has Get Info.

    Regardless, Paresh Devani solved this more than 2 yeas ago...

  • deus4ko Level 1 Level 1 (0 points)

    Its great that you know how to access file attributes section on both PC and Mac. Without your clarification people would have been baffled.

    Regardless of whether or not Paresh Devani solved this 2 years ago ( not sure how you know this anyway), the solution is not on here and could be useful to others. People still have this problem today.

  • Chris CA Level 9 Level 9 (78,005 points)

    deus4ko wrote:

    Its great that you know how to access file attributes section on both PC and Mac. Without your clarification people would have been baffled.

    Actually, they wouldn’t be baffled at all.

    Since this is the iTunes for Mac forum, PC users generally won’t look here. and Mac users generally don’t care about Windows Properties...

    Regardless of whether or not Paresh Devani solved this 2 years ago ( not sure how you know this anyway),

    I actually read the posts in threads, rather than blindly posting.

    I know it was solved 2 years ago because Paresh Devani selected the answer that fixed his issue 2 years ago & it was quoted in his original post… "This solved my question by Granavel on Feb 9, 2013 7:18 AM"

    the solution is not on here and could be useful to others. People still have this problem today.

    The solution is on here.

    However, had you bothered to read the original post, you would see that the solution you posted is irrelevant.

    Your solution will fix an issue, one that is completely unrelated to this thread...

     

    No response is necessary.