12 Replies Latest reply: Mar 2, 2013 5:45 AM by purplesuit
KateTTT Level 1 Level 1

Hi,

 

I have Mac OS X version 10.8.2.

 

Recently I found that I had to update my Flash player so did so but videos still came up with 'Blocked Plug-In' so I followed all the instructions on the Adobe website. unistalled it, reinstalled it, emptied the cache, restarted my mac, the whole thing but it is still not helping..

 

The version of Flash player that I have is the 11.5.502.149, the latest one.

 

Please help!


MacBook Pro, OS X Mountain Lion (10.8.2)
Solved by Linc Davis on Feb 9, 2013 9:19 AM Solved

If you're sure you've installed the latest version of Flash, take each of the following steps that you haven't already tried. After each step, relaunch Safari and test.

1. If you're getting a "blocked plug-in" error, triple-click the line below to select it:


/Library/Internet Plug-Ins

 

Right-click or control-click the highlighted text and select
  
Services ▹ Open
  
from the contextual menu. A folder should open. If there is more than one item in the folder with the words "Flash Player" (not "flashplayer") in the name, open the respective Info windows, check the version numbers, and delete all except the latest. You may be prompted for your login password. If you get the same error after doing that, re-download and reinstall Flash. Download it from this page:
   
   
Never download a Flash update from anywhere else.
    
2. If you get a "missing plug-in" error, select
 
Safari Preferences... Security
  
from the Safari menu bar and check the box marked Enable plug-ins.

 

3. Select

Safari Preferences... Extensions

from the Safari menu bar. If any extensions are installed, disable them.

4. In the Safari preference window, select

Privacy Remove All Website Data

Close the window. Then select

 ▹ System Preferences… ▹ Flash Player Advanced

and click Delete All. Close the preference pane.

  • clintonfrombirmingham Level 7 Level 7
    expertise.macosx
    Mac OS X

    Yep, 11.5.502.149 is the latest version - and I'm not sure why you're having problems with it. Although I use Firefox as my main browser, I always keep Safari open just to check on these things - and I'm not having any problems at all. If you go under the Help menu to Installed Plug-ins, does the Shockwave Flash plugin show as being installed?

     

    Clinton

  • KateTTT Level 1 Level 1

    When I open Flash Player it does say that it's installed and working..

  • clintonfrombirmingham Level 7 Level 7
    expertise.macosx
    Mac OS X

    But does it show as installed and enabled in Safari? Have to tried a YouTube video - what are the results?

     

    Clinton

  • KateTTT Level 1 Level 1

    It seems that it is only on safari as I have just installed firefox!

  • KateTTT Level 1 Level 1

    I don't know whether it is enabled for Safari, when I try to watch a Youtube video it says Blocked Plug-In.

  • clintonfrombirmingham Level 7 Level 7
    expertise.macosx
    Mac OS X

    Hmm - I'm able to view YouTube (and other Flash content) in both Safari and Firefox - I'm stumped: no idea why it's not working with Safari...

     

    Sorry,

     

    Clinton

  • dominic23 Level 8 Level 8
    expertise.macosx
    Mac OS X

        Safari > Preferences > Security

        Web content:

        Is the box next to "Enable plug-ins"  checked?

        Best.

  • Linc Davis Level 10 Level 10
    expertise.applications
    Applications

    If you're sure you've installed the latest version of Flash, take each of the following steps that you haven't already tried. After each step, relaunch Safari and test.

    1. If you're getting a "blocked plug-in" error, triple-click the line below to select it:


    /Library/Internet Plug-Ins

     

    Right-click or control-click the highlighted text and select
      
    Services ▹ Open
      
    from the contextual menu. A folder should open. If there is more than one item in the folder with the words "Flash Player" (not "flashplayer") in the name, open the respective Info windows, check the version numbers, and delete all except the latest. You may be prompted for your login password. If you get the same error after doing that, re-download and reinstall Flash. Download it from this page:
       
       
    Never download a Flash update from anywhere else.
        
    2. If you get a "missing plug-in" error, select
     
    Safari Preferences... Security
      
    from the Safari menu bar and check the box marked Enable plug-ins.

     

    3. Select

    Safari Preferences... Extensions

    from the Safari menu bar. If any extensions are installed, disable them.

    4. In the Safari preference window, select

    Privacy Remove All Website Data

    Close the window. Then select

     ▹ System Preferences… ▹ Flash Player Advanced

    and click Delete All. Close the preference pane.

  • Aymondo Level 1 Level 1

    Had exact same problem..working with FireFox but blocked in Safari. Open FlashPlayer from SysPrefrences go to Advanced and check for updates. It worked for me oddly enough!

  • J_wlh Level 1 Level 1

    I also have the exact same problem. After booting my macbook pro 15" mid 2010 model up, seeing 'Plugin blocked' on youtube and being prompted to download the newest version of FlashPlayer (11.5.502.149) on Februrary 9th 2013 I procceded with the download in hope it would fix the issue, but nope... I still have this problem only within Safari.

     

    I know using chrome is an alternative option but I personally preffer Safari and would very much like to find a fix.

     

    I work at an Apple Premium Resseler within the UK and me and guys had a look at it and have tired all of the above mentions to no prevaile. It pretty much stumped us and obviously assumtpions of another bodged Flashplayer update come to mind.

     

    If anyone can help or know's a way around it, adivce would be much appreciated.

     

    Thanks.

  • Aymondo Level 1 Level 1

    I did have version 11.5.502.149 installed..it still only worked with FireFox and not Safari. What I did was update Safari to the latest 6.0.2 version and when that didn't work I just opened Flash from Prefrences and pressed the Check Now button..was surprised it had an update available! When that updated was installed..Safari went back to working just fine.

  • purplesuit Level 1 Level 1

    Is there any way to stop the automatic "blocked plug-in" because I don't want my flash plug-in automatically blocked.  That defeats the purpose of installing click-to-flash.  I can't download 50MB (from home) any time Adobe gets nailed by another zero-day exploit (and creates more with the new update).