1 Reply Latest reply: Feb 9, 2013 6:42 PM by mdk90274
UR2SLO Level 1 Level 1 (0 points)

I've just bought an iPod classic to store my music collection, but it says it can't be used because it requires iTunes version 10.7 or later. (I'm currently running iTunes version 10.6.3) I can't download iTunes version 10.7 because my iMac is running on OS X version 10.5.8. I hadn't anticpated this problem as the iPod classic is a relatively old model, not updated since 2009. I didn't really want to buy new operating software for my Mac as well. Any ideas what to do please?


iPod classic, Mac OS X (10.5.8)