12 Replies Latest reply: Feb 18, 2013 12:21 PM by 916hyp
916hyp Level 1 (0 points)

I have my Aperture 3.4.3 library on a TimeCapsule.


A few days ago I suddenly got a note that there was a problem with the library and it wouldn't open. This was on my principal computer. After a while (repairing library and reparing permissions) I got it to open.


The problem is now that I can't view clips (MOV-files). I can see the thumbnail just fine in the Browser and the Split View, but not the clip itself, ie in the Viewer. And I can't start the clip.


When I look into the library itself I can find the file and it plays in VLC.

The wierd thing is that the whole library also plays and behaves normally on my second computer. Including all clips!


Any ideas on what to do?


The only thing I have done to this computer recently is the mounting of a SSD-drive (restored from a copy in TimeMachine).


I have restarded the computer.

I have checked the disk for permission-problems.


I guess the problem lies in the program itself on this computer? (Since there are no problems with my other computer).



Aperture 3, OS X Mountain Lion (10.8.2)
  • Frank Caggiano Level 7 (25,715 points)

    If the library works OK on the other computer then yes that would seem to rule out a library problem for now.


    BTW both computers are running the same OS and Aperture versions right? If not stop here and post back the OS and Aperture versions on the two machines indicating which belongs to the working system.



    I would look at the last thing you did before you started having problems on this computer:

    The only thing I have done to this computer recently is the mounting of a SSD-drive (restored from a copy in TimeMachine).

    you'll need to explain this in more detail. Is this now the system drive?  As a test I would go back to the configuration before you made this change and see if Aperture works. If it does then you know it is the problem has something to do with the change.

  • 916hyp Level 1 (0 points)

    Both computers are running OSX version 10.8.2 and Aperture 3.4.3. I usually update to the latest version out there, trying to keep it simple.


    What I did to the computer with the problem (a 15" MacBook Pro, 2.8 GHz Intel Core 2 Duo) was that I wanted to speed it up a little. So I bought a Samsung SSD (840 series) and installed it using a TimeMachine copy, using R-key startup to make an identical disk. Then I also enabled the TRIM on an advice from a friend (supposed to make the SSD more native?). I did this usan a small program downloades from the web.


    I think I was using Aperture without problems after this. At least once or twice, and then this all happened. It would be some hassle to remount the old drive, and restore an old copy?


    Bu the way, the other computer (on wich everything is workind dandy) is a slightly newer 13" MacBook Pro.


    Any advice is most welcome!



  • Frank Caggiano Level 7 (25,715 points)

    Again if the problem occurred after making the changes you made you should try to get back to the configuration that worked.


    Is the SSD installed as the internal root drive? If so then wipe the disk starting over but this time don't download and run the program you got from the web.


    Other things to try to isolate the problem:

    What happens if you make a new Aperture library and import a movie into it, does it play?

    What about if you make a new user and run Aperture as the new user and import a movie, does it play then?

  • 916hyp Level 1 (0 points)



    With ther persistance of a fool I'm still trying to avoid cleaning the drive (which is the internal root drive) and start all over...


    What I have tried since last is:


    - Import a new movie to the aperture library. No luck, same result. Grey screen, but a regular thumbnail.

    - I made a new library. Imported a picture, no problem. Imported a movie, same problem as before.

    - I opened the aperture library with iPhoto. No problem! Movies played well!

    - I switched user. Imported movie, same problem. New library, imported movie, same problem. Running from iPhoto, NO problem.


    Now I also downloaded Aperture again. Reinstalled, upgraded to 3.4.3. Opened old library, SAME PROBLEM!


    So. The problem is with my root-disk somewhere? I guess I have to reboot the whole thing... I'm not sure with what copy though... Aaargh. See problems...

    Any other way around this???

  • 916hyp Level 1 (0 points)

    Added info:


    When I try to import a movie clip (tried MOV and MP4 just for starters), I get a message saying "Import completed. 0 items were successfully imported", whatever that means. Aperture does not generate a new thumbnail for this "item" but creates a new project with 0 items. And I don't get a process bar indicating that any file is being transferred into the Aperture library. There are no files of any size that will show up in "Info".


    If I try this manuver in iPhoto, it will import the same file, into the same library, giving a progressbar indicating file transfer. It generates a thumbnail, and the file is playable without any problem!


    If I now go back and open the library with Aperture, it will display the new thumbnail, and it will acknowledge that the file has a size and is a film (under "info"), but It will not play.


    I have again gone over my computer, cleaning and reparing. I have resetted all settings to default.


    Any clues?

  • Frank Caggiano Level 7 (25,715 points)

    Best I can think of right now is to have a look in the Console logs and see if anything shows up.


    Open the Console (/Applications/Utilities/Console), make sure All Messages is selected in the lefthand column and then in the upper righthand corner, in the search box, try entering Aperture and see what comes up.


    Not sure why Aperture is the only thing not playing the video, especially if iPhoto is. It would seem to have something to do with the changes you made but perhaps that the problem appeared now is just a coincidence.


    Maybe the logs will give a clue.

  • 916hyp Level 1 (0 points)

    This is what I get whenever I try to view a clip:



    2013-02-18 16:50:18,758Aperture[674]Failed to communicate with qtkitserver: Connection invalid
    2013-02-18 16:50:18,759Aperture[674]Failed to initializeServer(), returned 5
  • Frank Caggiano Level 7 (25,715 points)

    Ok this problem appears on some systems if a cache file is missing from the OS.


    Look in /Library/Caches/ for a file called com.apple.xpchelper.cache If it is missing on the system that is not working look in the system that is.


    If the file is missing on the bad system and there on the good system you can just copy the file over. 


    The other thing you can try to recreate the file i it is missing is to open a terminal window and enter


    sudo /usr/libexec/xpchelper --rebuild-cache


    some users have reported that that works. I can;t vouch for it but one one has complained that it caused any harm to their system so it is worth a shot if you can;t copy the file from your other system.


    A reinstall of the OS should also fix the problem.


    Message was edited by: Frank Caggiano

  • 916hyp Level 1 (0 points)

    Neither system had a filed called com.apple.xpchelper.cache...


    But, recreating the file through the terminal worked!

    I typed what you asked, and it didn't work, until I RESTARTED...



    Up and running!

    Still no com.apple.xpchelper.cache file in sight though...



  • Frank Caggiano Level 7 (25,715 points)

    Glad its working.


    I just realized I entered the wrong path for the cache file. Should be




    If you look there you should see the file.



  • 916hyp Level 1 (0 points)


    Still no file by that name, anywhere. On this computer or the other...


    Everything still seams to work though...