11 Replies Latest reply: Sep 1, 2013 11:23 AM by Linds1111
HiH0 Level 1 Level 1 (0 points)

After my MBP goes to sleep it will not automatically reconnect to my WiFi.  I can manually connect it and it stays connected until it goes to sleep again.  Any ideas to correct this


MacBook Pro
  • leroydouglas Level 6 Level 6 (15,280 points)

    Which MacBook Pro do you have, model, size, year ?

     

    Have you run the >Software Update recently?

  • HiH0 Level 1 Level 1 (0 points)

    Macbook Pro,15",  first quarter 2102, Runninh OSX ver10.7.5 (no updates availalbe), 2.2 GHz Intel Core i7, 4GB 1333Mhz DDR3

  • leroydouglas Level 6 Level 6 (15,280 points)
  • HiH0 Level 1 Level 1 (0 points)

    Sorry, this did not solve the problem.  FYI I'm using a D-Link DIR 615 wireless router if thta helps.

     

    Thanks

  • SwankPeRFection Level 4 Level 4 (1,435 points)

    Make sure the router's on the latest firmware upgrade.  Does this happen everywhere with all WIFI hotspots or just at your house?  If it's just at your house, then it's an issue with the router.  Try the firmware upgrade first and then even possibly changing its config if necessary.  Sometimes certain types of security on it cause this issue.  You should be on WPA2/AES if at all possible.  I've seen dropouts happen on WEP or no security ones.  It's very possible that your WIFI doesn't have any security on it at all and that's why it doesn't reconnect back up.  It's like that by design on the Mac side of things.

  • OlyPil Level 1 Level 1 (0 points)

    My router is installed by Verizon and they set the name and password which I have used for the wireless connection of printer and MacBook. It has a WEP/WAP2 Key, so it should be pretty secure.

    The Verizon technician was here on Friday and couldn't solve the problem!!

    Maybe this printer is not compatible anymore with the OSX 10.7.5??

  • HiH0 Level 1 Level 1 (0 points)

    Sorry, nothing has been able to solve the problem.  I can reconnect after a "sleep" but it must be done manually.

  • SwankPeRFection Level 4 Level 4 (1,435 points)

    Click on the WIFI icon on your toolbar.  Select Open Network Preferences.  On the next screen make sure your location at the top is set to Automatic.  Select WIFI on the left and click Adanced at the bottom.  On the next screen make sure there's a checkmark under Remember network this computer has joined.  Then select your home network and remove it.  Hit OK on all those screens to confirm your changes.  Then go to Finder and hit Go/Utilities and run the Keychain app.  In there search for your WIFI network name you have at home and delete the entry for it.  Confirm it's deleted by "X" out of the search field and typing the name in there again.  If it doesn't find it anymore, you're good to go.  Reboot the laptop via the Apple menu icon and Restart.  When it comes back up, reconnect to your WIFI by clicking on the WIFI icon on your toolbar and selecting the name of your WIFI network from the list.  Enter your password for it (you will be asked for it since you deleted the keychain entry for it).  See if this resolves your issues.

     

     

    As a side note, if your D-Link router is revision is below a K1 revision number, you might want to try dropping the n band off on it and see if that fixes your connectivity issues, but just as a test.

  • HiH0 Level 1 Level 1 (0 points)

    Thanks,  looks like it solved the problem. 

  • MacTruly Level 1 Level 1 (0 points)

    Thank You for this, solved my problem too.  Our internet provider support guy said he's heard of a few Mac users with this problem but couldn't help me as you have.  Well done.

  • Linds1111 Level 1 Level 1 (0 points)

    I too have this problem - just started in the last couple of weeks (may have co-incided with installation of new Time Capsule - but it's all working fine).

     

    When I get to the advanced Network page you describe. All the options/network are greyed out and I can't remove the home network.

     

    Any ideas?!?