5 Replies Latest reply: Feb 9, 2013 2:54 PM by Linc Davis
headude Level 1 Level 1 (0 points)

I have a weird problem.

I have a 2010 MacBook Pro with 10.6.8 updated on all Apple apps. I started not being able to access "normal" websites (http://....). However, I have no problem accessing secure sites (https://....). I also have the same problem regardless of browser (Safari, Chrome, Firefox). I also am not able to download any email to "Mail" app (tho thankfully am able to view it in my Spammarrest account--a "secure" site). I backed up my hard drive, repaired permissions, verified and repaired disk (got one message that originally said "The volume...was found corrupt and needs to be repaired."). Repaired permissions. Have since run Verify (in Disk Utility) and three times it shows "OK".  Does anyone have ANY ideas?  I think it must be software related, perhaps doing with permissions (have reparied permissions twice).

 

My wife has no such problems on her iMac, so likely not router related (of course, I have rebooted everything several times).

 

Thanks anyone!


MacBook Pro, Mac OS X (10.6.8)
  • Linc Davis Level 10 Level 10 (147,565 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether your problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:
    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click  Log in.
    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • headude Level 1 Level 1 (0 points)

    Linc,

     

    WOW!  You know your stuff.  That solved BOTH issues. Now, from what you seemed to say, and by virtue of booting in SAFE mode, I imagine that I have some additional sleuthing to do, that is, figuring out exactly what third-party software I need to delete from my Mac. I don't suppose you have an easy way to determine this?

     

    If you ever get to Bend, OR look me up, I owe you 2 or 3 or 4 beers...

     

    Many thanks...you have no idea how you have alleviated my frustration level. I have been on Macs since 1984, solved almost every single thing I have had to deal with but this drove me up the wall. Thought I might have to reformat my drive (as Mr. Bill would say, "Oh, noooooooooo!")

     

    You da man,


    Dave K.

     

    <Email Edited By Host>

  • Linc Davis Level 10 Level 10 (147,565 points)

    The problem is not solved yet.

     

    Please read this whole message before doing anything.
      
    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
       
    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.

     

    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.

     

    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.

     

    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then either copy or drag it. The headings “Step 1” and so on are not part of the commands.

     

    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” and press return. You should then get a new line ending in a dollar sign.

     

    Step 1

     

    Triple-click the line of text below to select it:
    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'
     
    Copy (command-C) the selected text to the Clipboard. Then click anywhere in the Terminal window and paste (command-V). Post the lines of output (if any) that appear below what you just entered. You can do that by copy-and-paste as well. Omit the final line ending in “$”. No typing is involved in this step.
        
    Step 2

     

    Repeat with this line:
    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'
     
    This time you'll be prompted for your login password, which you do have to type. It won't be displayed when you type it. Type it carefully and then press return. You may get a one-time warning not to screw up. You don't need to post the warning. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.

     

    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.

     

    Step 3
    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'
     
    Step 4
    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null
      
    Important: If you formerly synchronized with a MobileMe account, your me.com email address may appear in the output of the above command. If so, anonymize it before posting.

     

    Step 5
    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null
     
    Remember, steps 1-5 are all copy-and-paste — no typing, except your password. Also remember to post the output.

     

    You can then quit Terminal.

  • headude Level 1 Level 1 (0 points)

    Linc,

    Again, you have solved the issue(s), though not without a few hiccups. I believe after following your instructions and subsequently deleting a program or two, I am back to a "happy mac" dude. Many, many thanks! Dave

  • Linc Davis Level 10 Level 10 (147,565 points)

    If you would care to say which programs you removed, it might be helpful to others who have the same problem.