Previous 1 2 Next 27 Replies Latest reply: Nov 29, 2013 11:50 AM by appleidlaurie Go to original post
  • Sue_Exeter Level 1 (0 points)

    I can't explain this, but it is back.  I did nothing. It just reappeared sometime during my drive into work this morning.  I really...do not understand.

  • wegras Level 6 (15,070 points)

    it is simple ...............it's a computer

  • jjgleim Level 1 (0 points)

    I'm having the same issue.  My camera app dissappeared yesterday (2/12/2013) after I ran some updates on some apps from the appstore.  Problem is, I don't remember which ones had the updates to know if one of them caused the issue because I hit the Update All button.  I did the usual searching around for it and nothing.

    • Can't find via Spotlight
    • On the lock screen, the option to slide up to activate the camera is gone.
    • No settings for Camera.
    • My other camera apps won't show a live image either.

     

    I am going to try a restore to see if that works.

  • jjgleim Level 1 (0 points)

    I did a restore back to factory settings and the camera is back and working.  I'm now in the process of restoring from one of my backups to see if it still remains.

  • Sue_Exeter Level 1 (0 points)

    The one thing I didn't do was restore to factory settings.  I did restore to a back up and that didn't work.  I was saving the restore to factory as a last choice, when the camera just reappeared all on its own without doing anything.

  • Rapha el123 Level 3 (655 points)

    This is very weird and I think that it would be a great help to many people if we could find out the route cause of this strange bug.

  • jjgleim Level 1 (0 points)

    I restored my latest backup and the camera is gone again.  Trying the factory reset again. The backup restore gave me an option to restore between a newer backup and an older backup.  Will try the later this time to see if that works.

  • jjgleim Level 1 (0 points)

    I got my backup restored and the camera app disappeared again.

     

    Is there a log that I can read to find out what apps I updated yesterday and see if I can't delete them off my phone to see if that brings back my camera app?

  • jjgleim Level 1 (0 points)

    Figured out the problem.

     

    The same day I ran the updates, I also changed setups for my work Google Apps email.  I have Microsoft Exchange email and I also have Google Apps for Education email.  I found directions online that allows users to use the Exchange setup on the iPhone for Gmail which adds the option of pulling in your Google Contacts which the current Gmail setup lacks.  So I thought, cool I can have both on my phone now.  So... I deleted my Google Apps setup and set the account up using the directions Google provides.  Everything works great except when I went back to my home screen, my camera is there and then it disappears.  When I delete my special Gmail setup, my camera comes back.

     

    Is it not possible to have two Exchange setups on your iPhone? (one MS Exchange & one Gmail)

     

    Here's the link to the directions on Google's website for the setup - http://support.google.com/a/users/bin/answer.py?hl=en&answer=138740

  • jjgleim Level 1 (0 points)

    I'm learning all kinds of stuff today.  Ok, on the Google Apps for Education Admin Dashboard, under Settings -> Mobile Settings there is an option under Device settings to "Allow Camera" that was not enabled.  I set my phone up again with those same directions, checked the box to allow the camera and my camera stayed this time. 

     

    Why does Google have the power to enable the camera on an iDevice? 

     

    I can see for Android since that's their product, but for Apple too?

  • Lawrence Finch Level 7 (34,986 points)

    It's a feature of the Exchange security profile, and Google uses MS Exchange for Google Apps sync.

  • Sue_Exeter Level 1 (0 points)

    This was not my problem. But I don't doubt it is somehow tied to Exchange since the 6.1 iOS update seems to have some bugs relating to it.

     

    For the record I haven't had any problems with my camera since it reappeared.

  • appleidlaurie Level 1 (0 points)

    Thank you...I had the same problem. Easy fix...once you know what to do :-)

Previous 1 2 Next