14 Replies Latest reply: Jan 20, 2016 11:53 AM by Rostum Consulta
camillajob Level 1 (0 points)

Before i don't have any problem calling someone.

But recently everytime i try to call any numbers may it be domestic or international numbers

my iphone will respone "You call cannot be connected please check your phone setting"

(for example, i try to call my mom cellphone number. Even though her phone is not turn off/busy, my iphone still reply me the same)

i checked my iphone setting already and i think everything is the same. Beside i'm the only one who use my phone. I also did RESET ALL THE SETTING but still the same.

I also visited my network provider just awhile ago. To inquiry maybe it was just my sim card. They check it and it was not my sim card. But the iphone it self. There's NO MAC/IPHONE store near me to fix this.

Please teach me how to fix this.

iPhone 3GS
  • KiltedTim Level 9 (50,310 points)

    That's not your phone telling you that, it's the cellular network.


    Contact your carrier again.

  • camillajob Level 1 (0 points)

    i did, tried to exchanged my sim card to put it to the other cellphone and it seems theres no problem. with it. I also tried to put other sim card from the other cellular network to my iphone, and still works the same.


    i dont think its the carrier network.

  • lendave07 Level 1 (0 points)

    Hi Camillajob!


    I just want to ask if you were able to resolve your fone's issue? Mine has the same problem. When i was in Europe i was able to call to the Phils...but when i arrived back to the Phils one month later, i would also receive the same response from the operator. My iPhone4s can send text messages, incoming calls and the 3G is working fine. The only problem is the outgoing call which i cannot resolve. I also went to the carrier and told me that it is the fone that has a problem already. I remember updating OS to 6.1.3. before this problem occur. I don't know if this caused the problem.


    Please let me know if you can help me as well if you were successful with yours.


    Best Regards,



  • lendave07 Level 1 (0 points)

    Hi Camilla,


    I accidently fixed the bug in my fone, the one with the same problem as yours, I just went to my Phone settings (the one with your number shown on top of the menu)..scrolled down to "SIM Applications" and simply activated my Gold Data option and that's it! It's all working now!


    Hope this helps!



  • camillajob Level 1 (0 points)

    Hi lendave07,


    Good to hear that your iphone is working now. Mine is still not

    i tried to do what you've said to me. But what i have on my iphone sim application are:

    -Buddy Balance

    -Text Offers

    -Call offers

    -Load wallet


    -Int'l Roaming


    -smart money


    -Sim Setting


    i've tried sim setting but mine only have:


    -voice mail on

    -prepaid card inq.


    I don't even have that my 'Gold data' option i guess ?

    do you know any option. I really want to fix this mess.

    Please help me.


    Thank you inadvance

  • lendave07 Level 1 (0 points)

    Hi again Camillajob!


    I think i know what caused the problem. It seems that the update is causing it. Mine is 6.1.3 and since the installation my fone went into that error mode. I tried to restore from an old update veraion and i got it Working, unfortunately ir didn't last long. As of today, im still having problems with it. I guess we need to wait for further update to resolve this.


    Aside from this all my music purchases are going shuffle mode (they won' play) it also says it cannot be found in the server. I'm also pisse off but i guess we just have to wait for the next update and hope and pray for things to work out finally well.


    Let's keep our hopes high!





  • MrJohn22 Level 1 (0 points)


    i had the same problem before and i just fixed it now. (thanks for the other forums)


    first i tried to ask my network provider what's the cause of the problem.

    i even ask them to give me a new simcard with the same number.

    but here is what they've done.


    they turned on my Location Services and have my phone search my correct time zone in date and time settings.

    after having confirmed my time zone, they turned the location services off again and restart my fone.

    then tried to make a phone call.

    surprised to know thats already fixed.

    that's it!


    but wait..


    after three days having my phone fixed, the same problem occurs.

    your call cant be connected. please check your phone settings.


    annoying isnt it?


    so i surfed the net and check for a fix.


    then tried this one.


    go to your



    and tap Show My Caller ID

    wait for it to load making sure that it ends up green (on)


    exit and try to make a phone call again and see the result.


    hope this one helps.

    by the way my fone is iphone5 and sim carrier is smart too..

  • Sweetberryphils Level 1 (0 points)

    Thanks mrjohn22. I have iphone5c and smart carrier. Faced the same problems. Their customer service was not able to fix it. The solution you gave was so simple and easy. And it fixed the problem 100%. Thanks so much for the help!!

  • accolade_25 Level 1 (0 points)

    Hey im also from the philippines and got the same problem. But hey, thanks for the info i got my iphone 5 fixed. Thank you so much guys :D

    It really helped.  Thumbs up.

  • Cat_five Level 1 (0 points)

    Thanks MrJohn22. I've been having the same issue for almost 2 weeks and your easy fix did the trick! Thanks!

  • jemdelasalas Level 1 (0 points)

    same issue.. I was out of the country for more than 10 months then when I came back I cant call any number.. then I did what u have said, but the "Show my Caller ID is not working, it's turned on but I really can't turn off and on if u know what I mean

  • theianpogi Level 1 (0 points)


  • N1cko Level 1 (0 points)

    Thanks. It works.. But apple should fix this issue...

  • Rostum Consulta Level 1 (5 points)



    Just to share, the root cause of this issue is not device-related but is actually network-provider dependent. Currently here in the Philippines, Globe allows anonymous call registration to their network as long as the SIM card can be identified. Smart, however, requires the mobile number to be validated as well.


    Given this, if the device is set to hide or not to broadcast the mobile number during a cal (Caller ID) then Smart will not be able to identify the SIM card and will not allow the call. Also, this problem will happen in any other device with the same settings.


    FYR. Thank you for your time.