Previous 1 2 Next 28 Replies Latest reply: Jan 29, 2014 11:14 AM by Douglas Webster
mynameisearl Level 1 (5 points)

Hi All,


I have an iMovie project that I have been working on for a number of years - building up slowly - adding various photo's and home movie clips with normal transtions - nothing complicated really bog standard stuff - iMovie has worked great for this and I have never had any issues until now.


I typicaly export this movie to a 720p HD by doing the Share into iTunes - again always worked fine until recently when I seem to now get the error messaging saying it could not be completed and gives me the code (-108).


The project itself is crica 600Mb, the movie length is currently around 1hr 12mins.


If I share to a lower format - such as mobile it seems to complete ok. Only seems to be when I share in HD.


I found this after adding a number of new photos and clips (About 2 mins worth) - if I delete them and go back to where I was it seems to work ok.


Is there a size limit? I cant find any information on this error (-108).


I have 34GB of disk space free.


Running iMovie 11, OSX Mountain Lion, All updates installed, MAC Book 2.4Ghz Intel Core i7, 16GB 1333 Mhz DDR3


Thanks in advance!

  • mynameisearl Level 1 (5 points)

    Having read much about this there is alot of theory about free space and that it needs to be defragmented. I have installed iDefrag and run - will let you know how I get on.

  • Bengt Wärleby Level 6 (19,450 points)



    Error -108 memFullErr  Ran out of memory [not enough room in heap zone]


    Turn off - TimeMachine usually works - re-try.

    (the Application down in the Dock or under Apple menu / System pref. - not the Device)


    Yours Bengt W

  • mynameisearl Level 1 (5 points)

    Hey Bengt,

    Thanks for the suggestion, unfortunatly I am still having the same error.

    iDefrag seem to run through ok overnight and I assume made any disk space I had contigous which is something I have read on on web that was thought to be a cause. Not in my case it appears.

    Also tried your suggestion of turning off TimeMachine, again unfortunatly this did not improve the situation and I am still getting the -108 error. I can only assume I have hit some sort of Project Limit either related to my project itself or the system. I think the only course of action I have now is to split my project into two pieces but just a shame really.

    Any other suggestions most welcome!

  • Bengt Wärleby Level 6 (19,450 points)



    Project lenght - I doubt


    Material used that iMovie can not use as Video Codec, photo file format and audio file format


    • Video Codec - I use interlaced SD .dv or AIC - lot's of .mov, .mp4 etc are NO Codec but containers and file need to be opened by QuickTime player and then Inspector [cmd+I] to find out what Codec video really is


    • Photo - I only use .jpg - NEVER .bmp or other - all converted to .jpg (GraphicConverter™)


    • Audio - NEVER .mp3 or other strange format - ONLY .aiff 16-bit 48kHz or from Audio CD .aiff 44.1kHz


    By splitting project into halfs - one can rather rappidly find the faulthing part. One cont. to split till all parts works OK




    Free space on Start-Up Hard Disk

    • > 25GB if only interlaced SD material is used (standard for DVD - PAL or NTSC)

    • if HD material then 4 - 5 times more is a safe level.


    Yours Bengt W

  • mynameisearl Level 1 (5 points)

    Well after going back through my time machine 6 months and trying old versions of the project which did work - and now no longer do not I can only assume this is disk space related or I have some sort of corruption of iMovie. Next step will be to transfer all my video to an external drive so as to create space on my MacBook - currently I have 50Gb so really surprised if this will resolve the issue. If anyone has any ideas of how to create a clean install of iMovie I would be very gratefull !!

  • mynameisearl Level 1 (5 points)

    Ok latest update:


    I moved all my video files to an external drive. This left 500GB free on my boot disc where iMovie is installed.


    The project still fails to share into iTunes as HD - I get the dreaded -108 error.


    If I share into iTunes as a Large file - it works fine.


    For info file contains only music I legaly own through iTunes, only photo's I legaly own through iPhoto and Movies that are home videos captured on either my Sony Handycam or Sony NEX5 camera. There is nothing special going on here which is all the more frustrating.


    Also - I have gone back 6 months on my time capsule and taken the same file at 6 different points in time which worked then with no issues and now even simply restoring those files and resharing in HD causes the -108 error on this project.


    Other projects much smaller in length 3 - 10 mins share fine in HD.


    Really at a loss so any help/advice would be welcomed.

  • mynameisearl Level 1 (5 points)

    Latest - Have tried aomsething I found relating to clearing the NVRAM/PRAM. No change

    Have tried duplicating the project - No change

  • mynameisearl Level 1 (5 points)

    Latest - Split the duplicated project in half going from 1hr 14 mins to a 35 mins project. Now comes up with an error -49 - still does not render in HD.

  • mynameisearl Level 1 (5 points)

    OK - so made some progress - I think.


    The smaller project I made which was 35 mins long that failed with the error -49, I split in half to circa 15mins and this worked!


    So - I duplictaed the orginal again and created another version 35 mins long - this failed error -49


    I then turned OFF Time machine - Rebooted - then before loading iMovie I ran the "sudo tmutil disablelocal" command from terminal.


    I then started iMovie, ran the HD iTunes Share on the 35 min movie and this WORKED.


    I will now trying and export the full orginal movie again 1hr 14mins worth using iTunes SHARE HD.

  • mynameisearl Level 1 (5 points)

    FAIL! Wow - this is really frustrating me!


    So back to square one with the orginal large movie but at least now I can only assume there is some sort of issue with the original project in the second half. I think the issue with time machine local backups is just another contributing factor to this.


    Will start with the original file again and start by removing 20 mins of the project which should roughly get me between the 35 min length that seems to work and the 1hr 14mins that does not. Hoping I can narrow this down to some sort of issue with a particular part of the project - not holding my hopes up as said right at the start - it works fine rendering to a large video. Just not HD!

  • mynameisearl Level 1 (5 points)

    Final Entry


    Ok - after much cutting, trial and error and days of work I have never really established a root cause for the -108 error. Nothing I did resolved the issue to the orginal project.


    The only work around I have found is to split the Original Project into two.


    What I found was that anything around the 60 mins mark and above just failed to render in HD and showed the -108 error.


    What worked for me was creating two project files - one around 57mins long - the other a part 2 - around 17 mins long. All using exactly the same source clips, photo's, music and transitions as the orginal.


    This now works. I guess having it split in two makes it a little easier to work with as I wont have to keep rendering the first part which does not change but really wish Apple would throw some light on this.


    Anyway - I hope all of the above at least proves useful for others.


    Good Luck

  • Bengt Wärleby Level 6 (19,450 points)

    Thank You for Your feed back


    If OK - I add this to my Error -108 suggestion text.


    And Thank You again for Your feedback as it leads us one step forward in solving this big problem


    Yours Bengt W

  • mynameisearl Level 1 (5 points)

    Final - Final update:-


    I think I was being a bit ambitious when I spoken about 57 minutes earlier - The maximum I can get to render in HD without getting the dreaded -108 is around 40 mins - Im keeping my large project in to <40 minute parts.


    Seems to be working.



  • mynameisearl Level 1 (5 points)

    Latest iMovie update does nothing to resolve this -108 issue.

Previous 1 2 Next