4 Replies Latest reply: Feb 12, 2013 6:34 AM by lllaass
Guadalup5 Level 1 (0 points)

I was told that my ipod needs to be updated because I have the 4.1 version.  I cannot buy apps from the app store or use youtube.  Please I need help

iPod touch, iOS 4.1