3 Replies Latest reply: Feb 11, 2013 4:48 PM by roaminggnome
factorysupercharged Level 1 Level 1 (0 points)

Cannot download apps. Says not compatible with this ipod touch or it says need ios 4.3


iPod touch, iOS 4.2