1 Reply Latest reply: May 3, 2013 3:28 AM by Roger Sinden
Roger Sinden Level 1 (130 points)

As the question asks, really.


I am so fed up with the flakiness of Home Sharing that it simply is not worth the hassle.  I have tried all the various support articles but to little avail. Seems the only way to get it to work is to close down everything and restart every day....not ideal. 


I use my iPod Touch out in my workshop. Access is via a Wireless Access Point hardwired back to the router.  I will leave the iPod touch connected for the night but when I get back in the morning, Shared has gone. Click on More.  Doesn't come back.  Switch off the iPod..switch it back on. Sometimes you will see shared.  Click on it.  Sometimes it just dumps out of Music.  Safari works fine which suggests that the network connection is OK.

  • Roger Sinden Level 1 (130 points)

    I have now resolved this and for the possible benefit of others will explain how, what and why.


    Switch inside the house to which is connected the Internet router and iMacs, printers etc. Ethernet cable from switch goes underground to a workshop. Plugged into the Time Capsule.  Then Ethernet cable from Time Caposule to Netgear WG604 wireless access point.  And the wifi connection used to feed my iPod Touch so I can use Home Sharing back to one of the iMacs.  Home Sharing has always given me a problem...often dropping out or even failing to connect without an awful lot of hassle.  But Time Machine seemed to behave itself and I could browse the web via Safari on the iPod Touch.  So network issues didn't really enter the fray.


    Then Time Machine started complaining that the last backup was delayed.  Drilling down in the logs I got the error message NetAuthConnectToServerSync failed with error: 64  But I could still access Time Machine from the iMac.  I could still ask Time Machine to Backup Now and it would.  But the scheduled automatic backup initiated from within Time Machine/OSX invariably always now gave the error message. 


    So to eliminate the long cable as a possible candidate causing the problem, I brought Time Capsule into the house and connected it directly to the switch.  Automatic backups went ahead flawlessly. Which got me round to thinking possibly about a dodgy ethernet cable (rodent attack/whatever).  However, replacing this cable would be a non-trivial task because although it ran in drainpipe underground and I had a pull-through in place, there was still a lot of messing about needed at either end to finish the routing.


    So I went off in search of some sort of network management software that I could set up to ping away all day and report any dropped packets.  I was recommended Fing.


    First thing I did was unplug all the individual remote components such as the Time Capsule, the access point etc and then run a Discover (which revealed all the IP addresses of devices connected on my network).  The result was a darn sight more accurate and comprehensive that the useless list provided by the Internet router.  As I gradually plugged in the remote devices I noticed a strange thing happen. The Access Point had an IP address of but then when I plugged in the Time Capsule, Fing reported a change of IP address/Mac away from the Access Point and to the Time Capsule.  But no other IP address was assigned to the Access Point.  Since all were on DHCP I did expect the router to sort this sort of thing out.  Trying to access the Time Capsule gave me a screen for the Access Point. Airport utility sometimes reported it could find the Time Capsule and sometimes it couldn't.


    It became obvious that for some reason I ended up with two devices having the same IP address.  Which under DHCP I thought should not happen.  But it had.


    So I unplugged the Time Capsule.  Accessed the Access Point and set it to a static IP address. Reserved the same address in my router. Reconnected Time Capsule.  Automatic Backups worked perfectly.  Airport Utility very happy with locating Time Capsule.


    And the icing on the cake is that the iPod now plays very happily with Home Sharing.