4 Replies Latest reply: Feb 12, 2013 7:49 PM by clue1019
clue1019 Level 1 Level 1 (0 points)

When I use Microsoft Office 2011, none of the special characters (such as Greek letters) show up. Instead, I see rectangular boxes. When the Word document loads, it almost looks like a macro runs.  I rebooted the computer in Secure Boot and the problem was corrected.  I then tried dissabling startup items and booting normally.  The problem returned.  Next, I looked at what non Apple kernels were loaded durring the normal boot proceedure. I dissabled most of them, but the problem continues.  I do not think reinstalling MS Office will help because the problem is abscent when I do a secure boot.  It is like something that loads durring normal booting is casuing a conflict.  Any suggestiions would be helpful?

 

Another note ... This problem pertains to Microsoft Office.  The fonts in Adobe CS6 show up correctly. I am running the latest edition of Mountain Lion.


MacBook Pro, Mac OS X (10.7.5)
  • Linc Davis Level 10 Level 10 (159,150 points)

    Back up all data.

    Launch the Font Book application and validate all fonts. You must select the fonts in order to validate them. See the built-in help and the support article linked below for instructions. If Font Book finds any issues, resolve them, then boot in safe mode* (by holding down the shift key at the startup chime) to rebuild the font caches. Boot again as usual and test.

    Mac 101: Font Book

    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode. In that case only, after running Font Book, launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Drag or copy — do not type — the following line into the Terminal window, then press return:

    sudo atsutil databases -remove

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. After running the command, reboot as usual.

  • clue1019 Level 1 Level 1 (0 points)

    I went to FontBook and validated all fonts (select all; validate fonts).  Then I trashed the fonts that had serious errors (red circle).  Afterwards, I restarted the computer with Secure Boot.  After logging in, I restarted the computer normally.  After OS X loaded I opened a Word document.  I still have the same problems with the special characters.  I should add that I temporily whiped out the all my preferences to make sure a preference did not cause the problem.

  • Linc Davis Level 10 Level 10 (159,150 points)

    Can you create documents with Greek letters in other applications, such as TextEdit?

  • clue1019 Level 1 Level 1 (0 points)

    I solved the problem.  I turns out the characters that appeared as square boxes were from the font "Symbol."  For some reason, there was a second font called "symbol" installed which casused the conflict.  I removed "symbol," and problem was fixed.  Thanks!