Skip navigation

Ipod touch 5 gen recovery problem. stuck in recovery

320 Views 2 Replies Latest reply: Feb 13, 2013 5:16 AM by lllaass RSS
ed are Calculating status...
Currently Being Moderated
Feb 12, 2013 10:37 PM

i tried updating my ipod to the latest version. but like many others my ipod is stuck in recovery mode. how can this get fixed? i even tried restoring it numerous times but nothing. it says it detects ipod in recovery mode and needs to be restored. nothing works. what should i do? what can i do? i dont want my data to erase and i dont have backup. this happened yesterday. all i can see is the usb itunes logo.

iPod touch, iOS 6

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.