13 Replies Latest reply: Mar 28, 2014 6:25 AM by Csound1
emaich Level 1 (0 points)

Hi, My Macbook Pro suddenly stopped picking up my personal wifi a few days ago. I have tried various options of the internet including deleting all passwords in Keychain, setting up a new connection etc., however none seem to work. Here is what exactly happened:


1. The internet was down in the area and the cable company got it fixed in a day or so

2. When the service came back, my ipad and blackberry picked up the wireless connection seamlessly, however, my macbook pro did not. It did pick up other connections in the area but not my personal one.

3. After trying some of the solutions researched online, the current status is that the computer mostly does not pick up any signal at all (neither mine nor other ones in the area).


Please do let me know some solutions I may try or let me know if I should be taking my computer to the apple store.


P.S. my software is all up to date and I am now connection via cable.



MacBook Pro (13-inch Early 2011)
  • Power-PC Level 2 (155 points)

    To clarify, can you detect other WiFi networks?

    Try deleting these AirPort preferences, then restart:



    1. From the desktop, pick the "go" menu.

    2. Then select "computer" and open Macintosh HD

    3. Navigate to Library>Preferences>SystemConfiguration


    4. Move the following files to the trash:




    5. Restart

  • emaich Level 1 (0 points)



    Thanks for the reply Power-PC. I tried the solution detailed above, but it did not work. Any other suggestions? I have been using a wired connection for the last two weeks and am anxious to get back to wireless.

  • CMCSK Level 6 (10,717 points)

    Since you did not provide any os information try all "linked" solutions pertaining to your os.


    First contact your ISP.  You need to confirm that the issue is not on their end.


    Change your router channel.  Sometimes this is all you will have to do.


    Power cycling the router.  Read the router's user manual or contact their tech support for instructions.


    System Preferences/Internet & Network/Network

    Unlock the padlock

    Locations:  Automatic

    Highlight Airport

    Click the Assist Me button

    In the popup window click the Diagnostic button.


    System Preferences/Network- Unlock padlock.  Highlight Airport.  Network Name-select your name.  Click on the Advanced button.  Airport/Preferred Networks-delete all that is not your network.

    Place a check mark next to "Remember networks this computer has joined."  Click the OK button and lock the padlock.  Restart your computer.



    http://support.apple.com/kb/TS1920 Mac OS: How to release and renew a DHCP lease



    No internet connection (wireless)

    Check to see if an extra entry is present in the DNS Tab for your wireless connection (System Preferences/Network/Airport/Advanced/DNS).

    Delete all extra entries that you find.

    Place a check mark next to "Remember networks this computer has joined."



    Other resources to check into:

    Troubleshooting Wi-Fi issues in OS X Lion and Mac OS X v10.6


    Configuring 802.1X in Mac OS X Lion and Later


    Non-responsive DNS server or invalid DNS configuration can cause long delay before webpages load




    How to diagnose and resolve Wi-Fi slow-downs


    Pv6 troubleshooting


    Mac OS X 10.6 Help:  Solving problems with connecting to the Internet


    OS X Mountain Lion: Check the status of your network connections


    OS X Mountain Lion: Requirements for wireless Internet access


    What Affects Wireless Internet?


    Solutions for connecting to the Internet, setting up a small network, and troubleshooting



    If using one of Apple's Airport routers, read its user manual or post in its forum area. If using a 3rd party router, read its user manual, contact their tech support department/website or post in its forum area.












  • emaich Level 1 (0 points)



    I finally called Apple support (AS)and the issue is resolved for the moment. For those facing the same issue, prior to calling AS, I had


    1. Done what Power-PC detailed above

    2. Deleted all my saved networks

    3. Powered down the router several times.


    Apple support asked me to


    1. Go to network preferences

    2. Get off the wired connection

    3. Check if the wirless icon in the left hand pane has a green "light" (radio button) - which it did.

    4. Click on the Wirelessicon in the left pane

    5. In the main pane, click on the Advanced button on the lower right side

    6. On the next screen (titled Wireless), click on TCP/IP in the horizontal menu at the top of the pane

    7. Click on the button that said renew DHCP lease

    8. Click OK


    This brought me back to the Main Network preferences screen. I could now see my network and connect.


    I then rebooted the computer and it did not pick up any WiFi networks. We went through the same steps again and I was able to pick up my network. The support person then requested that I power down the router and keep it off for a couple of mins. On restarting the router and the Mac, it automatically picked up my network. I am hoping that I have no more issues.

  • emaich Level 1 (0 points)

    Thanks all who replied with solutions. Much appreciated

  • CMCSK Level 6 (10,717 points)

    Thank you for detailing Apple tech support's solution.













  • jpr_88 Level 1 (0 points)

    In addendum;


    None of the above troubleshooting solutions provided a fix for my problem.


    It was as if every wireless network in a 5 km radius was being detected on my brand new macbook pro 15 apart from my own.


    This was a network that had been seamlessly connected to by mobile devices, consoles, other operating systems etc for a number of years.


    The fix was to switch the channel frequency setting on my billion router from 40hz/20z (whatever that means) to 20hz.


    Resolved for me. Hope that helps

  • Csound1 Level 8 (46,987 points)

    You reduced the channel bandwith by half, 40Khz to 20Khz. And if that works, stay with it.

  • jpr_88 Level 1 (0 points)

    I basically understand what I did. What I dont understand is the setting '40hz/20hz'. The other thing I have a problem with is why the macbook didnt pick my signal up without such a seemingly insignificant fix due to what I can only guess is a hardware compatability idiosyncrasy... I still have the warm tingles from finding a fix though.

  • Csound1 Level 8 (46,987 points)

    jpr_88 wrote:


    I basically understand what I did. What I dont understand is the setting '40hz/20hz'.

    It did not say 20hz, or 40hz.


    Read it again, once you know what it says I'll tell you what it does,


    Or read this.


    Channel spacing within the 2.4 GHz band[edit]

    In addition to specifying the channel centre frequency, 802.11 also specifies (in Clause 17) a spectral mask defining the permitted power distribution across each channel. The mask requires the signal be attenuated a minimum of 20 dB from its peak amplitude at ±11 MHz from the centre frequency, the point at which a channel is effectively 22 MHz wide. One consequence is that stations can only use every fourth or fifth channel without overlap.

    Availability of channels is regulated by country, constrained in part by how each country allocates radio spectrum to various services. At one extreme, Japan permits the use of all 14 channels for 802.11b, and 1–13 for 802.11g/n-2.4. Other countries such as Spain initially allowed only channels 10 and 11, and France only allowed 10, 11, 12 and 13; however, they now allow channels 1 through 13.[31][32] North America and some Central and South American countries allow only 1 through 11.



    Spectral masks for 802.11g channels 1 – 14 in the 2.4 GHz band

    Since the spectral mask only defines power output restrictions up to ±11 MHz from the center frequency to be attenuated by −50 dBr, it is often assumed that the energy of the channel extends no further than these limits. It is more correct to say that, given the separation between channels, the overlapping signal on any channel should be sufficiently attenuated to minimally interfere with a transmitter on any other channel. Due to the near-far problem a transmitter can impact (desense) a receiver on a "non-overlapping" channel, but only if it is close to the victim receiver (within a meter) or operating above allowed power levels.

    Confusion often arises over the amount of channel separation required between transmitting devices. 802.11b was based on DSSS modulation and utilized a channel bandwidth of 22 MHz, resulting in three "non-overlapping" channels (1, 6, and 11). 802.11g was based on OFDM modulation and utilized a channel bandwidth of 20 MHz. This occasionally leads to the belief that four "non-overlapping" channels (1, 5, 9 and 13) exist under 802.11g, although this is not the case as per Channel Numbering of operating channels of the IEEE Std 802.11 (2012) which states "In a multiple cell network topology, overlapping and/or adjacent cells using different channels can operate simultaneously without interference if the distance between the center frequencies is at least 25 MHz."[33] and section and Figure 18-13.

    This does not mean that the technical overlap of the channels recommends the non-use of overlapping channels. The amount of interference seen on a 1, 5, 9, and 13 channel configuration can have very small difference from a three channel configuration[34] and in the paper entitled "Effect of adjacent-channel interference in IEEE 802.11 WLANs" by Villegas this is also demonstrated.[35]



    802.11 non-overlapping channels for 2.4GHz. Covers 802.11b,g,n

    Although the statement that channels 1, 5, 9, and 13 are "non-overlapping" is limited to spacing or product density, the concept has some merit in limited circumstances. Special care must be taken to adequately space AP cells since overlap between the channels may cause unacceptable degradation of signal quality and throughput.[36] If more advanced equipment such as spectral analyzers are available, overlapping channels may be used under certain circumstances. This way, more channels are available.[37]


    20Mhz is the normal channel width, 40 is excessive (unless you live far from anyone else there will be overlap between the chanls you use, and other channels that others may be using)

  • Csound1 Level 8 (46,987 points)

    Graphics seem not be be showing, so click on the blank space where they ought to be and you will see them.

  • jpr_88 Level 1 (0 points)

    hmm, i did have a quick read. Here is the configuration i was confused about.


    Screen Shot 2014-03-28 at 11.59.31 pm.png


    It seems strange that this specific broadcast spectrum configuration would impact my macbooks connectivity. Am i missing something?

  • Csound1 Level 8 (46,987 points)

    There is a fixed amount of bandwidth available, 40Mhz channels occupy the same space as 2.25 20Mhz channels do (guard bands use the rest) so they overlap other channels.


    Specifically, if you are on Ch3 and use a 40Mhz width you will be occupying space allocated to Ch's 2 thru 6.


    What channels in your location are unoccupied (probably none) so which are the least used, and don't forget that you now need 3 adjacent channels to accommodate the 'fat' channel you chose.


    Stay at 20Mhz, it will be more reliable.