5 Replies Latest reply: Feb 18, 2013 12:36 PM by nickfromks
nickfromks Level 1 Level 1 (0 points)

I'm currently trying to modify the file, user/library/preferences/SystemConfiguration/com.apple.Boot.plist in order to enable the use of an apple usb external superdrive on my early 2009 iMac-- the internal drive is dying. When I open this file in Get Info, the permissions are, system read & write, admin read only, everyone read only. If I attempt to add owner, nick (Me), with read & write permissions, and then the repair permissions, I get this--

 

ACL found but not expected on “Library/Preferences/SystemConfiguration/com.apple.Boot.plist”

Repaired “Library/Preferences/SystemConfiguration/com.apple.Boot.plist”

 

Apparently, it doesn't like having two users with read & write permissions, but system can't be removed from the permissions list.

 

In terminal, I can make the desire changes to the file, but it has no apparent effect-- i.e., the iMac still won't allow use of the external superdrive. The discs are read for a few seconds, and then ejected.

 

I'm guessing I have a problem with user permissions, but I have no idea how to fix it. Any suggestions?

 

thanks,

 

nick


iMac, OS X Mountain Lion (10.8.2), early 2009 20" iMac 2.66 ghz
  • Niel Level 10 Level 10 (278,380 points)

    Instead of changing the permissions, use TextWrangler to edit the file, or if you're comfortable working in the Terminal, the sudo nano command.

     

    (76836)

  • nickfromks Level 1 Level 1 (0 points)

    I've used terminal to change the file, and those changes appear as they are supposed to, but it doesn't have the desired effect, i.e., the computer still won't allow operation of the superdrive. Other people with similar systems and OS are able to make it work.

     

    Does anyone know why on my system, "system" has read & write permissions, but I, as owner, am not even listed in the permissions list for this file? (I haven't checked to see what the case is on other files.) This doesn't seem to be the case for others, where the owner has read & write permissions, and "system" isn't even on the list. It may be irrelevant to why this isn't working, but it's the only thing I can think of at the moment.

     

    BTW, it doesn't seem to matter if I change the permissions or not. It doesn't work any way I do it.

  • Linc Davis Level 10 Level 10 (164,070 points)

    The permissions of the file are correct. Don't change them. You're trying to hack your system based on information from some random website. That's a bad idea in itself. If the hack doesn't work for you, just don't do it.

  • nickfromks Level 1 Level 1 (0 points)

    Thanks-- you're probably right. Just making sure that it isn't something simple that I can do to make it work.

     

    Wish Apple could do something to make this device work with all their machines, but I guess there are copyright issues that prevent them from doing so.

  • nickfromks Level 1 Level 1 (0 points)

    I had Apple replace the superdrive with another unit, and it works just fine. So it was a hardware problem, not a permissions problem.