8 Replies Latest reply: Apr 3, 2013 9:50 AM by fruhulda
indychris Level 1 (0 points)

I've been waiting to install Mountain Lion on my late 2011 2.2GHz Quad-core i7 until I was certain that my most important software would run efficiently. So, yesterday I finally did my full backup and installed X.8 with updates. Everything went picture perfectly. All my apps work fine so far except for some Ambrosia software, but I was expecting that, so no worries. I have noticed one aggravation, though. I do quarterly newsletters for an NGO in Pages. I have done them for years. I began one last week under the Lion OS and everything was perfectly fine as it always has been. Now, when I go to work on the same newsletter (very same file) in Pages under Mountain Lion, the typing is horridly unresponsive. I type and it takes a second or better for the text to show up. I can literally be halfway through a line of text before it appears in the document. Everything looks fine, but the lag is utterly distracting.


I've checked my activity log and I'm not even using half of the 8GB of RAM installed, so I don't think it would be a memory issue. And in all other apps the typing works just fine (including Safari right now that I'm running with the Pages document open). What's even more confusing to me is that if I open a new document with a blank page, the responsiveness is normal there as well.


Now the newsletters are pretty graphic intensive, but that's never caused any issues before.


Does anyone know what could be causing the problem and possibly have a solution?


Many thanks!

  • Jerrold Green1 Level 7 (29,960 points)



    My advice to you would be to give the system some slack. Leave it on overnight without sleeping it. There are a lot of background operations that happen on a new system load and I think your responsiveness will improve with time.



  • PeterBreis0807 Level 7 (34,572 points)

    How much room do you have left on your hard drive?


    OSX likes 20% of the HDD to be free to write temporary files on.


    You are running your system on the internal HDD?



  • indychris Level 1 (0 points)

    I've got about 73GB remaining on a 750 GB Scorpio Black drive.


    Yes, the OS is native on the internal HDD.


    While I know that I'm down to about 10% of the space available, the peculiar thing is that it's ONLY Pages that gives me unresponsive typing.

  • PeterBreis0807 Level 7 (34,572 points)

    That is definitely too little free space and Pages because of its page layout is much more demanding than just plain text or word processing apps.



  • indychris Level 1 (0 points)

    So what changed in ML to cause this? The issue popped literally overnight after installing ML over Lion.

  • PeterBreis0807 Level 7 (34,572 points)

    Did you note how much free space was on your drive before you upgraded?


    OSX has always needed 10-20& free space on the hard drive. Do a backup and clear off files you don't need to hand.


    If you are surprised at the disk usage, get a Duplicate file finder utility and also check your iTunes and iPhoto collections.


    If you chose to archive your old system on your HDD when you upgraded because that will take up a large chunk of the drive.



  • indychris Level 1 (0 points)

    As I suspected, the issue seems to have nothing to do with available disk space. I've moved many of my larger media files to an external drive, freeing approximately 207GB on my 750GB drive. I've made sure all permissions are correct and ran Disk Warrior to ensure that directories are in working order. This seems to be entirely a Pages issue after upgrading to ML. I guess I'll be submitting the issue to Apple knowing that I'll be living with this issue for quite some time apparently.

  • fruhulda Level 6 (15,120 points)

    Is that the only thing you have tried? Have you tried Pages in another user accounton the machine? You can create a new account in the System preferences accounts. Login and try Pages If it works better than in the original account it is probably a preference file that needs to be deleted. Come back an tell us the result.