6 Replies Latest reply: Feb 20, 2013 6:03 PM by Frank Caggiano
donalbertino84 Level 1 (0 points)

I just downloaded Aperture. It started once after installation but now shows library error message and shuts down right after opening it. Any ideas?

MacBook Pro, iOS 6.1.1
  • Ernie Stamper Level 8 (37,545 points)

    What Library?



  • fnc Level 1 (0 points)

    I have just experienced the same problem. Aperture has been working OK fro months.

    The library I see referenced is:


    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000



    Application Specific Information:

    dyld: launch, loading dependent libraries



    Dyld Error Message:

      Library not loaded: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

      Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture

      Reason: image not found



    Binary Images:

           0x1029d2000 -        0x103127fff  com.apple.Aperture (3.4.3 - 3.4.3) <01A802BA-0100-3F80-947C-A8FEA4726352> /Applications/Aperture.app/Contents/MacOS/Aperture

           0x10334a000 -        0x103353ff7  com.apple.PhotoFoundation (1.0 - 10.17) <C40F985F-9C0A-389A-9E21-684EB0A5B160> /Applications/Aperture.app/Contents/Frameworks/PhotoFoundation.framework/Versio ns/A/PhotoFoundation

           0x1033cd000 -        0x1038edfff  com.apple.RedRock (1.9.4 - 310.33) <9B94495A-2267-3684-B6E8-9FE3D4B46495> /Applications/Aperture.app/Contents/Frameworks/RedRock.framework/Versions/A/Red Rock

           0x103bf5000 -        0x103c78fff  com.apple.iLifePageLayoutCore (1.0 - 200.9) <8AAC1EB9-5823-3624-A525-635C2A77C34E> /Applications/Aperture.app/Contents/Frameworks/iLifePageLayoutCore.framework/Ve rsions/A/iLifePageLayoutCore

           0x103cd6000 -        0x103cdbfff  com.apple.iLifePhotoStreamConfiguration (3.4 - 2.5) <906317D7-09FF-3B77-8F35-01BB74C0109C> /Applications/Aperture.app/Contents/Frameworks/iLifePhotoStreamConfiguration.fr amework/Versions/A/iLifePhotoStreamConfiguration

           0x103ce8000 -        0x103d19ff7  com.apple.iLifeAssetManagement (2.7 - 40.34) <E4E1A39C-E8AE-31D5-9C50-B392EBAD7447> /Applications/Aperture.app/Contents/Frameworks/iLifeAssetManagement.framework/V ersions/A/iLifeAssetManagement

           0x103d49000 -        0x103d56ff7  com.apple.iphoto.AccountConfigurationPlugin (1.2 - 1.2) <0F515DED-D77E-3E4F-876D-F5CE596A844C> /Applications/Aperture.app/Contents/Frameworks/AccountConfigurationPlugin.frame work/Versions/A/AccountConfigurationPlugin

           0x103d6c000 -        0x103e0fff7  com.apple.MobileMe (13 - 1.0.4) <9A7FCC99-67CE-3F5E-98BB-9079B305087F> /Applications/Aperture.app/Contents/Frameworks/MobileMe.framework/Versions/A/Mo bileMe

        0x7fff625d2000 -     0x7fff6260693f  dyld (210.2.3) <A40597AA-5529-3337-8C09-D8A014EB1578> /usr/lib/dyld

        0x7fff8cfe2000 -     0x7fff8cff1ff7  com.apple.opengl (1.8.6 - 1.8.6) <720CC06C-0D01-37AE-BB3D-D7F0242B262A> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

        0x7fff8e007000 -     0x7fff8e007fff  com.apple.CoreServices (57 - 57) <9DD44CB0-C644-35C3-8F57-0B41B3EC147D> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

        0x7fff8e26d000 -     0x7fff8e30aff7  com.apple.PDFKit (2.7.2 - 2.7.2) <DE5BE2EF-2570-3792-B1C3-AAD45765F533> /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/PDFKit.framew ork/Versions/A/PDFKit

        0x7fff8f6ef000 -     0x7fff8f96fff7  com.apple.AOSKit (1.05 - 151) <A34E8584-797C-318F-9E25-937A710C68AB> /System/Library/PrivateFrameworks/AOSKit.framework/Versions/A/AOSKit

        0x7fff901a7000 -     0x7fff90355fff  com.apple.QuartzCore (1.8 - 304.0) <BDC66714-F60C-386D-A773-F897D1E87AB6> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore

        0x7fff94b3f000 -     0x7fff94b3ffff  com.apple.Accelerate (1.8 - Accelerate 1.8) <6AD48543-0864-3D40-80CE-01F184F24B45> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate

        0x7fff94ce2000 -     0x7fff94ce2fff  com.apple.Carbon (154 - 155) <372716D2-6FA1-3611-8501-3DD1D4A6E8C8> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

        0x7fff94d10000 -     0x7fff94e9afff  com.apple.WebKit (8536 - 8536.26.14) <7C4D5DE6-7153-3E54-8D4F-BB2E9AE74878> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit

        0x7fff94e9b000 -     0x7fff94e9bfff  com.apple.Cocoa (6.7 - 19) <1F77945C-F37A-3171-B22E-F7AB0FCBB4D4> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

        0x7fff9555e000 -     0x7fff955cbff7  com.apple.framework.IOKit (2.0 - 755.18.10) <142E19DD-1C8D-3D61-ABC8-83994A73279F> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

        0x7fff95610000 -     0x7fff95661ff7  com.apple.SystemConfiguration (1.12.2 - 1.12.2) <E095637C-457F-3D8F-AE32-A032F9D5A46C> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

        0x7fff9586e000 -     0x7fff95874fff  com.apple.DiskArbitration (2.5.1 - 2.5.1) <F7DAF7CC-5893-3F06-9168-3B0192B66D15> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

        0x7fff95ad9000 -     0x7fff95da9fff  com.apple.security (7.0 - 55179.1) <639641EF-8156-3190-890C-1053658E044A> /System/Library/Frameworks/Security.framework/Versions/A/Security

        0x7fff9854c000 -     0x7fff9854cfff  com.apple.ApplicationServices (45 - 45) <A3ABF20B-ED3A-32B5-830E-B37831A45A80> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services

        0x7fff99111000 -     0x7fff992fafff  com.apple.CoreFoundation (6.8 - 744.12) <EF002794-DAEF-31C6-866C-E3E3AC387A9F> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation



    Is this suffucient data.

    Thanks for any help

  • fnc Level 1 (0 points)

    I'm sorry to see that there is no response to my question.

    I have tried wiping out Aperture completely, including the plist files then installing again from the App Store with the same results.

    I tried starting with Option/Command pressed with exactly the same error.

    Any suggestions?

  • Frank Caggiano Level 7 (25,715 points)

    You hijacked anthers thread, that is not a good way to get responses to a question you have. You should have started a new post.


    Given what your crash dump shows I'd guess you have Final Cut installed. You need to restore the missing framework shown here


    Dyld Error Message:

      Library not loaded: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager

      Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture

      Reason: image not found

    You can get it off a backup if you have one or else just reinstall the OS

  • fnc Level 1 (0 points)

    Thank you Frank. I now have Aperture working agaim. I reinstalled OSX.

    I apoligise for jumping on another perons post - it appeared to be the same problem. I am new to this and have yet to learn the etiquette.

    Frank Curtis

    p.s. I just tried to click the Solved flag, but I assume that, as I was not the original poster, I cannot award the points. Sorry

  • Frank Caggiano Level 7 (25,715 points)

    Welcome to the forums, BTW.


    The reason we try to keep hijacking to a minimum is not because we're trying to control or censor the conversations here but to make the forums more usable for everyone including the person doing the posting.


    In your case it took 5 days to get an answer. Normally once I look at a post and decide I have nothing to contribute I don;t go back to it unless the original poster adds something. If I see a new poster add to a thread I assume its answering the OP's post not asking a new question.


    Had you asked this as a new question on the 10th I (or someone else) would have  jumped on it right away.


    And the reason I've gone into this detail is because very often mentioning thread hijacking is taken as a great insult. I was dragged over the coals in another post today because of this issue and wanted to make the reasoning behind this clear.


    Glad your problem is fixed


    And yes only the original poster can award helpfuls or solved so don't worry about it.