8 Replies Latest reply: Nov 19, 2015 4:06 AM by alasdairfromcardiff
Schwaben10 Level 1 Level 1
expertise.applications
Applications

I just tried to save an Excel document to a folder I've had on my computer for years and got the following message:

 

You do not have permission to save files to MacIntosh HD:Users:[etc..].

 

This has been my computer since I bought it 3.5 years ago; I've never run into this before and have never put any user restrictions on it. How do I get rid of this?

 

Thanks.


iMac, Mac OS X (10.6.1), Mac
Solved by BDAqua on Feb 16, 2013 2:28 PM Solved
Hi, in Finder, do a Get Info on that folder... is it Locked? What rights does it say for you?
Reply by Hgrafs95 on Aug 15, 2015 8:06 AM Helpful
My files weren´t locked, but I could not save because I had "/" in my filename

All replies

  • BDAqua Level 10 Level 10

    Hi, in Finder, do a Get Info on that folder... is it Locked? What rights does it say for you?

  • Schwaben10 Level 1 Level 1
    expertise.applications
    Applications

    Thanks. For some reason in Get Info, it was checked "Locked." I just had to uncheck it.

  • BDAqua Level 10 Level 10

    Great news, thanks!

     

    Nobody knows why exactly, but it happens often enough.

  • Loden1111 Level 1 Level 1

    Thanks from me too! i found a very complex answer elsewhere that required logging into terminal after a reboot. You provided a simple, elegant, and effective answer.

  • ScooberFan Level 1 Level 1

    I have the same problem. I tried to save a picture from an email and it says that I do not have permission. The answer is to go to Finder and Get Info and change the permissions but the file is not there (because it's in an email and I don't know where the email temp file is - too much trouble). I can search for the name of the picture eg IMG_0035 (in Finder) but all that does is find the email not the photo. I can't find the photo file in finder and therefore I cannot apply your solution. This is stupid. My computer, my email, my photo! I don't want to do this every time. I'm the administrator. How do I change this so it never asks again for any file?

    MacBook Pro Mac OS X 10.6.8

  • Hgrafs95 Level 1 Level 1

    My files weren´t locked, but I could not save because I had "/" in my filename

  • BillieBillie Level 1 Level 1

    I have similar prob.: Scanned file cannot be saved to desktop. "An attempt to save scanned items to the requested location has failed. Please check that the destination exists, has sufficient storage space for your files, and that you have permission to save files to this location.". And there is no "get info" tab. This seemed to start when I was trying to upgrade iPhoto and read one solution was to set up another Log-On person as an Administrator.

  • alasdairfromcardiff Level 1 Level 1

    Thanks - perfect!