Previous 1 2 Next 17 Replies Latest reply: Feb 18, 2013 2:39 PM by BDAqua
AppleIIplus Level 1 Level 1
expertise.macosx
Mac OS X

My wired mouse and BT trackpad frequently start selecting everything that the pointer rolls over. Then starts selecting and copying and imitates dragging and dropping text all over the screen.  Even after restarting, shutdown, resetting preferences for the mouse/trackpad only give temporary correction to the problem. When it happens, control only returns when 'Force Quit' is used because when you move the pointer to the top header of whatever application is on top the

'beachball' appears.  Thanks.


iMac, Mac OS X (10.7.5)
Solved by BDAqua on Feb 16, 2013 8:37 PM Solved

Good work, does seem like a HW issue... what all peripherals are connected?

Reply by AppleIIplus on Feb 18, 2013 1:17 PM Helpful

Once again thank you for all your ideas and input.  Finally got some control over the 'console' under the 'all messages' heading and saw some activity on 'remote wakeup' and the _setMultitouchReport error and subsequent 'Could not send DATA command via interruput channel.'  Then I decomissioned the touch pad and things have settled down completely for the last few hours without any of the selecting everything moused over.  Should have been more thorough with testing the touchpad (I was just taking it out of the room) and ultimately removed its batteries.  I will miss it.  Maybe the A store can address this.  Many Thanks again, I was ready to pitch the whole thing off the deck for a final reboot.

All replies

  • BDAqua Level 10 Level 10

    Hi, seems one of the 2 is going out, if the wired Mouse is an Apple one I'd suspect that first, try disconnecting that when it happens.

  • AppleIIplus Level 1 Level 1
    expertise.macosx
    Mac OS X

    The wired mouse is a 3 button Apple product and I only put into service because the trackpad went south. I even took my wife's trackpad and set it up and had the same result.   I just tried changing the dragging preference and things have settled down for now, until I started typing this response and the selection bar is appearing at random locations in this text and 'selecting all' as I finish this.  Aaargh.

  • BDAqua Level 10 Level 10

    In System Prefs>Mouse, try swirching the Primary Mouse button to the right buton, does that do the same thing?

  • AppleIIplus Level 1 Level 1
    expertise.macosx
    Mac OS X

    Switching the Primary to the right button has seemingly corrected the issue at the moment, I will continue to relearn the new positioning.  But as I type the problem reappears.  Now it is getting difficult to complete this session of typing.

  • BDAqua Level 10 Level 10

    One way to test is to Safe Boot from the HD, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, Test for problem in Safe Mode...

     

    PS. Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive

     

    Reboot, test again.

     

    If it only does it in Regular Boot, then it could be some hardware problem like Video card, (Quartz is turned off in Safe Mode), or Airport, or some USB or Firewire device, or 3rd party add-on, Check System Preferences>Accounts>Login Items window to see if it or something relevant is listed.

     

    Check the System Preferences>Other Row, for 3rd party Pref Panes.

     

    Also look in these if they exist, some are invisible...

     

    /private/var/run/StartupItems

    /Library/StartupItems

    /System/Library/StartupItems

    /System/Library/LaunchDaemons

    /Library/LaunchDaemons

  • AppleIIplus Level 1 Level 1
    expertise.macosx
    Mac OS X

    The safe boot found a lengthy list of permissions in need of repair the first few are interesting the remainder seem to be all printer. The first one pasted here is the only one that had the 'warning' notation (the ubiquitous ignore this information software litter). The problem persisted in safe mode and is still present upon normal reboot.  The only 3rd party prefs showing in system prefs was Adobe Flash.  Nothing in accounts was out of the ordinary.  The last list of startupitems had a couple of printer items that were crossed out and the folder is now empty with the exception of a long list of invisbile files associated with the /private/var/run/ in all of the listed locations.  Interestingly all that clicking and scrolling with the trackpad was error free.  When I went to reload a few Safari pages the problem reappeared. The whole problem started with the trackpad, which I stopped using and reinstalled the wired mouse.  When the mouse started acting up, is when I tried here.  Thank you for your efforts by the way. Would you have any other ideas.  Does it not seem to be software related because it is affecting a wired/wireless interface.  Where is the common point for these guys?  Thanks again.

     

    Repairing permissions for “Macintosh HD”

    Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent” has been modified and will not be repaired.

  • BDAqua Level 10 Level 10

    Good work, does seem like a HW issue... what all peripherals are connected?

  • AppleIIplus Level 1 Level 1
    expertise.macosx
    Mac OS X

    Connected items:  Wired Apple Keyboard, Apple BT Trackpad, 4 port powered USB hub (w/HP printer and 18 in 1 media card reader/writer), 500GB OneTouch4 Plus external HD via USB, and that's it.  This was quit difficult to get this text entered and input via the Forum.  The insertion selection bar is opening anything it scrolls over, and any open doc is being minimized and sent down to the docking station.  I have to maneuver the insertion bar around icons etc.  Thanks again.

  • BDAqua Level 10 Level 10

    Try it without the USB Hub attached, also might try pulling the KB cord out & see if the Mouse acts right then.

  • AppleIIplus Level 1 Level 1
    expertise.macosx
    Mac OS X

    Problem still persists with KP and Hub disconnected.  Another aspect is that when I put the computer to sleep, after a few minutes it will awaken on its own.  Typing in text edit right now and it is auto select the last character/word/all until I click off in a blank area.  My old G5 never gave me this much trouble, nor my 1st gen IMac, Performa Mac, 1st gen Mac, Apple II+.

  • BDAqua Level 10 Level 10

    Same here, my Qudra/630 still runs every day, never a single problem.

     

    So, have we tried typing witthout the Mouse connected, or Mousing without the KB connected?

     

    Open Console in Utilities & see if there are any clues or repeating messages when this happens.

     

    Any Bluetooth devices around? Is BT enabled?

     

    If you turn off Airport does that change anything?

  • AppleIIplus Level 1 Level 1
    expertise.macosx
    Mac OS X

    Only BT is the trackpad, Airport is off (always is), Console has logs in a folder called 501, and they look to be normal (rather large files) activity.  With the way my mouse control is working really hard to examine closely, constantly selecting and click dragging whatever is on screen. 

  • BDAqua Level 10 Level 10

    And the Console log shows no new entries as this is happening live?

  • AppleIIplus Level 1 Level 1
    expertise.macosx
    Mac OS X

    The last console log is dated 2011-07-02 for OS 10.4.11.  The other logs in folder 501 are console.log.0 thru .9 and have even earlier header dates.  Nothing appears on them while I have been typing or mousing

     

    When I put the puke to sleep, it wakes up on its own after a few minutes.  If that helps.

Previous 1 2 Next