3 Replies Latest reply: Jan 12, 2014 7:34 PM by bruckner7th
bruckner7th Level 1 Level 1 (10 points)

Here's the problem: In GarageBand, I'm unable to access ALL  presets in Pianoteq 4.

 

I've located Pianoteq as an Audio Unit Module (in the upper pop-up of the Edit tab) but when I click on the lower pop-up ("Manual") only  Grand Piano modules and presets are available. In other words, I can't choose any OTHER models, such as those for Electric Pianos, Chromatic Percussion, Steel Pans or Predecessors. Yet I CAN access every one of those modules from within the Pianoteq app.

 

Disclaimer: I'm currently running the DEMO version of Pianoteq 4. Is this perhaps a limitation of  demo mode and once I purchase Pianoteq 4 I WILL be able to access and record all Pianoteq modules and presets from within GarageBand? Or, is there something else I need to do to access those "missing" modules?

 

 

GarageBand '11, Version 6.0.5

Pianoteq 4, Standalone, 64-bit, Version 4.2.1 (demo)


iMac (21.5-inch Mid 2011), OS X Mountain Lion (10.8.2), 2.8 GHz Intel Core i7, 16 GB
  • 1. Re: How do I access ALL presets in Pianoteq 4?
    dalrmi Level 1 Level 1 (0 points)

    Hi bruckner7th, unfortunately I don't have an answer about your issue, what I can say about the DEMO mode it's limited to some keys that doesn't work and 20 minutes of functioning.

     

    Anyway can I ask you instead how did you do to use Pianoteq into GarageBand ? I own GarageBand '11 and I'm finding issues, this is what I've done:

     

    "Pianoteq 4 STAGE"comes with AU (.component) and VST file, I can find it on my iMac at the following path:

    • /Library/Audio/Plug-Ins/Components/Pianoteq 4 STAGE.component
    • /Library/Audio/Plug-Ins/VST/Pianoteq 4 STAGE.VST

    In my Audio Plug-Ins user's folder I can see nothing of them:

    • /Users/roberto/Library/Audio/Plug-Ins/Components
    • /Users/roberto/Library/Audio/Plug-Ins/VST

    I added a new AU called TB_Isone.component into /Users/roberto/Library/Audio/Plug-Ins/Components then I delete the file com.apple.audiounits.cachefrom the path /Users/roberto/Library/Caches and finally started GarageBand, it opens telling me to refresh the AudioUnit section (GarageBand is going to execute the scan of 25 Audio Unit installed! --> why 25 plugins ?)
    If I try to add a new master effect from the list of "Effetti Audio Unit" I can see the following:

    • AUBandpass
    • AUDelay
    • AUDistortion
    • AUDynamicProcessors
    • AUFilter
    • AUGraphicsEQ
    • AUHighShelfFilter
    • AUHiPass
    • AULowPass
    • AULowShelfFilter
    • AUMatrixReverb
    • AUMultiBandCompressor
    • AUNetSend
    • AUParametricEQ
    • AUPeakLimiter
    • AUPitch
    • AuRogerBeep
    • AUSampleDelay
    • TB_Isone

     

    Then the TB_Isone Audio Unit is recognized by GarageBand and I can use it.

     

    Unfortunately doing the same with Pianoteq 4 STAGE.component doesn't work (copying it from /Library/Audio/Plug-Ins/Components/ to /Users/roberto/Library/Audio/Plug-Ins/Components/ folder).

     

    How could I do to solve this issue ?

     

    Thanks, regards.

  • 2. Re: How do I access ALL presets in Pianoteq 4?
    Jacob3005 Level 1 Level 1 (10 points)

    Hey Bryckner7th

     

    Maybe you already solved your problem. I had exactly the same problem solved it, and I think the answer needs to be posted in this discussion:

     

    In Garage Band double click on a track to get this menu on the right. If you've installed pianoteq, you should be able to choose the settings shown on the picture below.

    Now, click on the picture of the orange ball with sound coming out from it just to the left of the pop-down menu. Now the pianoteq menu appears, and you should be able to use the entire libary of piano teq including all effects. Good luck

     

    Skærmbillede 2014-01-12 kl. 14.18.27.png

     

     

     

  • 3. Re: How do I access ALL presets in Pianoteq 4?
    bruckner7th Level 1 Level 1 (10 points)

    Brilliant! That did the trick! It's a clunky way (through GarageBand) to access the other Pianoteq instruments, but the point is, now I CAN access those instruments through GB. Thank you!